Reply
 
Thread Tools Display Modes
Old 02-05-2012, 04:18 PM   #1
Now a "Top Member"
 
EdJunior's Avatar
 
Join Date: Feb 2010
Location: Roman Forest, TX
Posts: 1,368
LP Hoses

Well, I'd been having lots of trouble with my gas in my Cat. And the Tums was just not working. (sorry) The last time I filled my primary LP tank, the big green twist knob kinda separated from the seals. And it just never seemed to seal very well anyway. And I could never get the automatic changeover thing to work. Plus, all the hoses were stiff as anything. So I decided to replace the whole kit and kaboodle. I replaced everything except the hose going between the two tanks. I didn't feel like taking the plugs out to deal with that one.

I replaced the original changeover regulator with a Marshall. I'll let you know how it works. All the hoses are now much more flexible and easier to work with, and so far I have not detected any leaks or gas smells. And I suspect my tanks won't be mysteriously empty anymore!
__________________
Ed and Sharon
2010 Wildcat 28RKBS
2011 Ford F-250 XLT, 6.7L PSD
Ride-Rite Airbags and Airlift wireless remote compressor...nice!

I thought I was wrong once, but I was wrong!
EdJunior is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 07:34 PM.