Reply
 
Thread Tools Display Modes
Old 03-03-2013, 09:03 PM   #11
Senior Member
 
tonyz's Avatar
 
Join Date: May 2009
Posts: 125
Quote:
Originally Posted by rockwood06 View Post
Maybe a bad sail switch, if the switch went bad the unit will shut down because this is what proves air flow, and or photo cell, if the photo cell can not see the flame because either bad or dirty it will shut the gas valve down and will not start back up....
Is there an access to the photo cell and anything particular to clean it with? Now that it is home, I hooked up to shore, full propane, and I hear a click about every 20 seconds from the furnace until it shts itself off after about 3 minutes of no heat.
__________________

__________________
Tony Z
tonyz is offline   Reply With Quote
Old 03-03-2013, 09:21 PM   #12
Senior Member
 
Join Date: Sep 2007
Posts: 3,260
Quote:
Originally Posted by tonyz View Post
Is there an access to the photo cell and anything particular to clean it with? Now that it is home, I hooked up to shore, full propane, and I hear a click about every 20 seconds from the furnace until it shts itself off after about 3 minutes of no heat.
Clicking is good as long as it is sparking to light the propane, if no spark then the photo cell can not see the flame because there is none but do you hear the fan motor coming on, this would be the draft motor, this is what actives the sail switch, once the air is proven then the gas valve will open, but again no spark no flame the system will shut down after the draft motor runs for a few minutes to clear the unburn gas out of the fire box. For the most part all of the componets should be accessable from the out side of the camper.

One other simple thing to check go out side and make sure that the fresh air intake is clear, there are two chrome ports mark "HOT" on the unit one is an intake and the other is exhaust....with out it operating look inside of both of these ports, they must be clear from bug, bees or anything else.
__________________

__________________
rockwood06 is offline   Reply With Quote
Old 03-03-2013, 10:17 PM   #13
Moderator Emeritus
 
Dave_Monica's Avatar
 
Join Date: Sep 2007
Location: Ontario, Canada
Posts: 4,329
Here's a link to download the Suburban furnace troubleshooting guide to help you out... Forest River Forums - Downloads - Suburban furnace troubleshooting

Dave
__________________


Nights camped in 2013 - 55, 2014 - 105, 2015 - 63
Dave_Monica is offline   Reply With Quote
Old 03-03-2013, 11:00 PM   #14
Senior Member
 
Join Date: Aug 2011
Posts: 200
Thermocouple?
__________________
brookside is offline   Reply With Quote
Old 03-04-2013, 12:22 AM   #15
Senior Member
 
tonyz's Avatar
 
Join Date: May 2009
Posts: 125
Quote:
Originally Posted by Dave_Monica View Post
Here's a link to download the Suburban furnace troubleshooting guide to help you out... Forest River Forums - Downloads - Suburban furnace troubleshooting

Dave
Sweet, now I have some reading to do at work in the morning, thank you
__________________
Tony Z
tonyz is offline   Reply With Quote
Old 03-05-2013, 04:46 PM   #16
Explorer
 
Join Date: Sep 2012
Location: CA
Posts: 342
probably no help

I had a similar issue happen; heater worked fine for 2 days and then just would not light. It would cycle but not light. I was in the Mojave dessert the night before Easter so I figured it would take two more days to have a technician do any warranty service. I did all the advice listed above and then dove in.
I broke out the factory paper work(wire diagram and schematic) a multi meter and at 12am while the family slept I put on my head-lamp. My heater, probably yours too, is tight/stuffed in there the ducting is a pain and all the corners and edges are sharp. To make a three hour story shorter I went through: signal from thermostat, all the inner-locks(safety-switches) tapped on the solenoid valve(will be magnetic when energized), repositioned the igniter. I had this heater all but out and on the floor of the camper, lines were not quite long enough. I could not find any obvious problem and I start thinking about energizing(light it up) to really see whatís going on. Then my Own Personal Internal Safety Switch goes off and I give up. Had I been at home with no one else in the camper I would have energized it. So I put it all back together and gave it another try and it lit. I have no idea what fixed it and was/am nervice about it not working again but its never happened again. So problem could have been a sticky switch, sticky solenoid valve, a loose wire or igniter alignment.
If your good with a multi meter and donít mind a few cuts and have a wire diagram and a schematic and a few jumper wires you can do it. I would recommend, do all the basics up to tearing it out and then take it in to a reputable shop.
In my last camper my wife put an umbrella over the exhaust duct outside and the heater had similar symptoms, would not stay lit. Umbrella got moved and all good, all but the umbrella it was ruined.
Good luck, let us know what happens
John
__________________
YoungKopernik is offline   Reply With Quote
Old 03-05-2013, 09:17 PM   #17
Haulin' Camp
 
KewlKamperz's Avatar
 
Join Date: Jul 2012
Posts: 75
Quote:
Originally Posted by tonyz
So, in the middle of the night, the furnace kicked off and would only blow cool air. Propane tank was near full, so it wasn't that. Any ideas?
We had a similar problem once. It turned out to be a mud dauber nest.
__________________

__________________
2012 26TBUD
2004 Suburban
3 Kids
2 Dogs

KewlKamperz is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 02:34 PM.