Thread Tools Display Modes
Old 03-18-2012, 06:27 PM   #1
Junior Member
Join Date: Dec 2011
Posts: 9
Awning2009 233S

All of the Sudden I am having a problem releasing the Awning Black clips from One side of my 2009 Rockwood 233S.
Anyone have any suggestions??
It seems to have just started this past month or so, Every time I go to release and set up the One side closest to back of the camper it will Not Release??.
The One side releases like it always did, and the back One forget it. I also noticed that When I Roll it up I now have to pick up the braces as well and lift them onto where they Secure.
Not sure what I need to do,, Adjustment or new brace??
Any Help Appreciated.
big2na is offline   Reply With Quote

233, 233s, awning

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Virginia Campgrounds

Reviews provided by is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 03:10 PM.