Reply
 
Thread Tools Display Modes
Old 06-22-2009, 06:50 PM   #1
Pete
 
gartonhl's Avatar
 
Join Date: Jun 2009
Location: Fulltiming
Posts: 166
Lippert hydraulic slide & level system

I have a 2005 Georgetown 325 DS. All working fine until a couple of weeks ago. Found 7.5 amp blown AUX fuse under steps by house batteries and replaced .

Now, power leveler console in dash operates in "all extend", but, 3 levelers go down-D front, Pass front, D rear and then living slide goes out, not Pass rear---I have to do that one separately. I've checked hydraulic valves and all are closed and tight.

Any one experienced a similar situation?
__________________

__________________
gartonhl is offline   Reply With Quote
Old 06-23-2009, 12:17 PM   #2
CLASS "A" Senior Member
 
cfsoistman's Avatar
 
Join Date: Nov 2008
Location: Upperco, Maryland
Posts: 3,135
I haven't had any issues with my levelers thank goodness but you may want to contact Lippert directly and explain your situation. Hope this link helps.

http://www.lci1.com/

Here's a troubleshooting link. If it doesn't load use the above link and choose LIP under the SUPPORT Column. This is # 0021.

http://www.lci1.com/LIP/0021.pdf


__________________

2007 Georgetown 370TS
aka - RAYNMKR

Driver: Charlie
Navigator: Sheri
cfsoistman is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 01:48 AM.