Thread Tools Display Modes
Old 03-25-2015, 12:21 AM   #11
Junior Member
dhuard's Avatar
Join Date: Sep 2014
Posts: 23
Update..... Situation resolved.

I had a mobile RV repair company come out after forest river said that the blown 5amp fuse could not be the issue because the sliders work together on 1 15amp fuse. When I told the RV repair team this finding they focused on the switch/relay and slide control unit.
The switch had power, the relay could be hear working and after 1.5 hours could not find the slide control unit. Tried to get more info out of the FR tech but they don't seem to answer the phone and only answer emails once in the am.....

We decided to go back to the fuses in the battery compartment area and we switched out the blown 5amp.

After installing the 5amp fuse... Everything worked as it should.
Very frustrating that there are not good diagrams and evan after getting a response back from FR they tell me that it can't be a 5amp fuse.

Just wanted to update everyone just in case you have a similar issue.

2012 Georgetown

dhuard is offline   Reply With Quote
Old 03-25-2015, 07:18 PM   #12
Junior Member
Join Date: Jun 2014
Location: Massachusetts
Posts: 14
Fifth wheel slide out problem also- 5th Wheel F.R. Signature model

Well, must be catching! Our slide outs stopped working today (all three). We checked fuses inside but seem to be ok. We read other messages, but cannot seem to find any other fuses or cannot locate near the battery as others suggested. Any help on where to locate these fuses will be much appreciated. We are in a rest area in New Mexico - and long way from Mass.

Dubedubedo is offline   Reply With Quote
Old 03-25-2015, 08:56 PM   #13
Left Coast
Join Date: Dec 2014
Location: vancouver,washington
Posts: 11,394
Send a message via Yahoo to bob caldwell
Had same problem....fuses okay in power center. Started looking for the famous...could be anywhere....fuse, never have found it if there is one. Next checked for power at switch...none. Broken wire/ loose connection? Checked connection, all okay. So, I ended up jumping to other slide switch and opening/ closing, one slide at a time, have not had a problem since. I also powered up dead feed wire, working from switch back toward power center... no body home. Have to live with it.
Bob/Linda, 99 Dodge 2500 Cummins,2010 8280 Rockwood Ultra-lite 5er, PullRite Superglide----- I'm retired......but work part time as a pain in the ass!........... USMC.
bob caldwell is offline   Reply With Quote
Old 03-27-2015, 09:22 PM   #14
Junior Member
Join Date: Jun 2014
Location: Massachusetts
Posts: 14
Fifth wheel slide out problem also- 5th Wheel F.R. Signature model

Thanks to the Forum we found the other fuse in back of the battery box. My husband installed an inline fuse and rewired everything and the slides are working fine now.

Thank you Forum!

Dubedubedo is offline   Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Virginia Campgrounds

Reviews provided by is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 02:10 AM.