Reply
 
Thread Tools Display Modes
Old 05-16-2013, 01:45 PM   #1
Senior Member
 
iluvlcy's Avatar
 
Join Date: May 2011
Location: Broken Arrow, OK
Posts: 354
Slide motor?

The past few times out whenever we bring slide in the motor sounds slow? It slides in ok but when it is all the way in it does not make that clicking noise unless i let go of switch and hit it again. Is motor going out?
__________________

__________________
Pam & Don
2003 Ford Expedition EB
2011 Rockwood 2304s

108 days camped 2013
74 days camped 2014 so far
iluvlcy is offline   Reply With Quote
Old 05-16-2013, 01:49 PM   #2
Senior Member
 
fonzie's Avatar
 
Join Date: Sep 2010
Location: Eastern Ontario
Posts: 3,237
First check your battery voltage if above 12 volts when operating your slide.
__________________

__________________
Fonzie
2011 Rockwood 8319SS with ProPride 3P hitch/GoodYear Marathons/TST TPMS 507
2008 F250 Lariat CC SB 6.8L V10 4.10 axle ratio (NITTO TERRA GRAPLER G2 LT275/65R20E)
Yamaha 3000iseb generator:Progressive Ind. EMS-HW30C : Eastern Ontario
Nights Camped: 2011(21) 2012(36) 2013 (17) 2014 (18) 2015 (18) 2016 (36) 2017 (32)
fonzie is online now   Reply With Quote
Old 05-23-2013, 03:51 PM   #3
Member
 
Join Date: Aug 2012
Posts: 53
Is the clicking sound normal, my 2104s makes this sound on one motor only when extending the slide out using house power.

cantho
__________________
cantho is online now   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 09:12 PM.