Reply
 
Thread Tools Display Modes
Old 04-16-2013, 02:46 PM   #1
Member
 
pr_dog's Avatar
 
Join Date: Apr 2013
Location: Eastern Passage, Nova Scotia, Canada
Posts: 50
Slide outs won't work

The slides on my Georgetown 373DS will not work. it is as if there is no power supplied to the system. I have checked the fuses in the Battery Control Center and it was ok. I have read from other posts that if the battery voltage was too low when trying to extend a slide that a reset switch will pop and have to be reset. The high amperage from the slide system tripped it due to low batteries. I plug the MH in to house current, apply the emergency brake and put ignition switch into accessory position. Batteries are fully charged. Still No movement. The hydraulic motor works because the leveling system works fine. Can somebody out there advise me where the reset switch is located or what to do to get it working again.
__________________

__________________
pr_dog is offline   Reply With Quote
Old 04-16-2013, 02:48 PM   #2
Member
 
Join Date: Feb 2010
Posts: 89
There is a 50amp flip fuse up above the batteries to the left...this needs to be reset!

Had a 373DS....did experience once failure of slides to move due to overloading circuit!

George
__________________

__________________
ynott96 is offline   Reply With Quote
Old 04-16-2013, 03:06 PM   #3
Member
 
pr_dog's Avatar
 
Join Date: Apr 2013
Location: Eastern Passage, Nova Scotia, Canada
Posts: 50
Quote:
Originally Posted by ynott96 View Post
There is a 50amp flip fuse up above the batteries to the left...this needs to be reset!

Had a 373DS....did experience once failure of slides to move due to overloading circuit!

George
Is this fuse the same one that works with the leveling jacks or is it only for the slides? If so how do I reset it?
__________________
pr_dog is offline   Reply With Quote
Old 04-16-2013, 03:25 PM   #4
Member
 
Join Date: Feb 2012
Posts: 73
Remove the keys from the ignition. My GT will not work if the ignition is in accesory.
__________________
Bill M
2012 Georgetown XL 360
2011 Chevy Equinox - 2006 Chevy Avalanche
Bill m is offline   Reply With Quote
Old 04-16-2013, 05:40 PM   #5
Member
 
pr_dog's Avatar
 
Join Date: Apr 2013
Location: Eastern Passage, Nova Scotia, Canada
Posts: 50
I tried it with the key removed. Nothing works. With the key in accessory ant the switches on the control panel operated no sound or anything. When I turn to key off and operate the switches I can hear the component on top of the motor switch modes to change the direction of rotation. The motor never operated. Some where there is a fuse or relay or something that is not working for the slide outs. The motor works fine for the leveling jacks. I hope someone out there can help. Please
__________________
pr_dog is offline   Reply With Quote
Old 04-23-2013, 03:19 PM   #6
Member
 
pr_dog's Avatar
 
Join Date: Apr 2013
Location: Eastern Passage, Nova Scotia, Canada
Posts: 50
Bill M was right. The key was removed and when I tapped the hyd pump motor and it worked hence the slides worked. Further investigation revealed that ATF had penetrated the motor as was noticed at the plug that one removes to manually crank it. Tapping it makes it work and has worked since. I will take it to my dealer and have it looked at for possible dealer replacement.
__________________

__________________
pr_dog is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 09:24 AM.