Thread Tools Display Modes
Old 09-09-2013, 05:35 PM   #1
Junior Member
Join Date: Sep 2013
Posts: 1
Tick tick tick slide outs do not move

Ok well story goes, wife buys fifth wheel while hubby at work..
and he is actually looking forward to it then when we go to pick it up the slides do not budge and the leveling jacks are 1 cm per 3 min in moving.

The bedroom one was out 6 in and a rv guy we called said slide it all the way out then it can go in. sooo we did, manually but after sliding it out it didn't go in at all. Other 2 we havent seen move at all.
RV repair came out loosened the hydraulic lines till slide could be pushed into fifth wheel we took it home and nope. it does not work.

Heres the deal though: we are not sure if it is a electrical issue or motor issue. Dad tends to think it is a wiring issue or a battery since when you try to use the motor it clicks like a car battery with no correct connection. The jacks also are extremeeeeely slow. It goes a little bit then stops, let it sit and then little bit and stops.
this is a 1997 Travel Eze 35' Fifth Wheel, 3 slides
#1 If i need to replace/rebuild Dewalt motor can it be done? #2 the Lippert slider motor maybe switched in its place if needed?
Before we can concentrate on that, we need to figure out the power issue. The common denominator between the two things not working is electricity. Even with a jump they do not go up and down or in and out. Both are seperate units. Batteries are not best but not super bad. the wiring to them is a bit strange however. 1 wire neg to neg, other wire hot to hot. then 2 small wires, 1 black 1 purple, small guage though (assume for hydraulic motor for slides?) Both of those on one post. 2 batteries total. Shouldn't there be another fat wire?
I appreciate any help you can give. thanks

xanevias is offline   Reply With Quote
Old 09-09-2013, 05:58 PM   #2
Moderators' Assistant
bikendan's Avatar
Join Date: Jan 2007
Location: Camano Island, Washington
Posts: 10,205
since your 5th wheel is not a Forest River product, i doubt if anyone here can help other than generic help. maybe someone here owned a Travel Eze before.

i would suggest you also post on a non-brand specific forum, like where owners of all different brands are members.
their 5th Wheel Forum might have some Travel Eze owners there, who could be more helpful.

Dan-Retired Firefighter/EMT
Shawn-Musician/Entrepreneur/Wine Expert
and Zoe the Wonder Dog(R.I.P.)
'07 Roo 23SS pushing an '07 Chevy Avalanche
Equalizer WDH and Prodigy BC
bikendan is online now   Reply With Quote
Old 09-09-2013, 07:00 PM   #3
Senior Member
jtstromsburg's Avatar
Join Date: Jul 2011
Location: Stromsburg, Nebraska
Posts: 1,579
Sounds like a dead battery to me, but I'm sure that's been tried.
Sorry I'm not much help, but I haven't dealt with hydraulic slides much.
Joel and Teresa
2016 Sabre 34TBOK
2006 GMC 3500 CC LB DRW 4X4
jtstromsburg is offline   Reply With Quote

slide, slide out

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Virginia Campgrounds

Reviews provided by is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 08:17 PM.