Reply
 
Thread Tools Display Modes
Old 05-06-2015, 12:15 PM   #21
Phat Phrog Stunt Team
 
TURBS's Avatar
 
Join Date: Aug 2011
Location: Iowa
Posts: 34,337
Quote:
Originally Posted by retiredcamper47 View Post
I had the same problem until I installed a battery cut-off switch. I located the switch on top of the battery box cover and used the positive cable. Yes I know there has been discussions on this forum about using the negative vs the positive side of the battery to cut off. My Co detector and stereo were the culprits that I found. Lord knows whatever else was sucking power from the battery. Even tho the stereo was turned off, the dial window remained lit up. I installed a small solar panel (from Harbor Freight) on top of my propane cover and attached it directly to my battery. No problems since.

Bob
I used positive cable as well!

TURBS
08 duramax tuned n modded, 32bhok Sabre
2015 camping "4 nights"
__________________

__________________
TURBS is offline   Reply With Quote
Old 05-06-2015, 12:15 PM   #22
Junior Member
 
Join Date: May 2015
Posts: 9
Quote:
Originally Posted by TURBS View Post
Your battery will go dead unless you unhook it or install a battery disconnect or lastly keep it plugged in.
There are a few parasitic draws that will run your battery down every time.

I think you mean converter not inverter.



TURBS
08 duramax tuned n modded, 32bhok Sabre
2015 camping "4 nights"
Thanks I get the 2 confused.
__________________

__________________
Blazincfd is offline   Reply With Quote
Old 05-06-2015, 12:17 PM   #23
Phat Phrog Stunt Team
 
TURBS's Avatar
 
Join Date: Aug 2011
Location: Iowa
Posts: 34,337
Quote:
Originally Posted by Blazincfd View Post
Thanks I get the 2 confused.
No problem

Is it actually humming? Or is it the fan running ?

TURBS
08 duramax tuned n modded, 32bhok Sabre
2015 camping "4 nights"
__________________
TURBS is offline   Reply With Quote
Old 05-06-2015, 12:34 PM   #24
Junior Member
 
Join Date: May 2015
Posts: 9
It is actually humming. I think the problem began when the Dirt Devil no longer worked about 2 years ago. This is what happened last year: In camper to pack and clean. overhead lights dimmed then would go back up. At campsite it would do the same thing. Then we tried to use our AC units and the lights would dim, fridge would go off and start to look for propane. The "converter was humming(whining type of sound.) Shut lights off and one AC unit. Things would be ok for a while then the process would start over again. Put in recharge battery. That almost worked for the next camping trip. Went to have serviced. They said it was the battery. They put in a new battery. Went to pick it up and the battery everything was dead. Could not even use electric front jack to lift tongue to put on truck. Left I there. They said they looked for shorts and things. They thought the fridge was left on when they did a "search" for the problem. Called them Monday and they said that the battery was dead again after they put in. Now they are yet again searching the problem. I told them int he beginning that we thought it was the converter. What does it sound like to you
__________________
Blazincfd is offline   Reply With Quote
Old 05-06-2015, 12:36 PM   #25
Junior Member
 
Join Date: May 2015
Posts: 8
Battery not charging

So do I have to call the dealer when power works fine when plugged in but nothing with the battery? The battery is brand new so from what I see the charger is not working. Is there a quick fix or something to try? All breakers work and all fuses are fine, even the one in front under the a-frame. Scratching my head here trying to avoid calling the dealer.
__________________
japacker is offline   Reply With Quote
Old 05-06-2015, 12:45 PM   #26
Phat Phrog Stunt Team
 
TURBS's Avatar
 
Join Date: Aug 2011
Location: Iowa
Posts: 34,337
Quote:
Originally Posted by Blazincfd View Post
It is actually humming. I think the problem began when the Dirt Devil no longer worked about 2 years ago. This is what happened last year: In camper to pack and clean. overhead lights dimmed then would go back up. At campsite it would do the same thing. Then we tried to use our AC units and the lights would dim, fridge would go off and start to look for propane. The "converter was humming(whining type of sound.) Shut lights off and one AC unit. Things would be ok for a while then the process would start over again. Put in recharge battery. That almost worked for the next camping trip. Went to have serviced. They said it was the battery. They put in a new battery. Went to pick it up and the battery everything was dead. Could not even use electric front jack to lift tongue to put on truck. Left I there. They said they looked for shorts and things. They thought the fridge was left on when they did a "search" for the problem. Called them Monday and they said that the battery was dead again after they put in. Now they are yet again searching the problem. I told them int he beginning that we thought it was the converter. What does it sound like to you
Sounds like your converter is junk or headed that way!

TURBS
08 duramax tuned n modded, 32bhok Sabre
2015 camping "4 nights"
__________________
TURBS is offline   Reply With Quote
Old 05-06-2015, 12:47 PM   #27
Phat Phrog Stunt Team
 
TURBS's Avatar
 
Join Date: Aug 2011
Location: Iowa
Posts: 34,337
If it's a wfco there's a very diagnostic chart in the library here on the forum or on WFCO's website to test your old one.

TURBS
08 duramax tuned n modded, 32bhok Sabre
2015 camping "4 nights"
__________________
TURBS is offline   Reply With Quote
Old 05-06-2015, 04:16 PM   #28
Junior Member
 
Join Date: May 2015
Posts: 9
Just heard from the service person. He said that we have to have battery switch disconnected or the LP detector will drain it in 24 hours. I think my money is still on the converter. Why else would the lights dim and nothing work during the day. Thank you your advice. When we get it back I am going to look at the convert for the numbers to see what we can replace it with.
__________________
Blazincfd is offline   Reply With Quote
Old 05-06-2015, 04:18 PM   #29
Phat Phrog Stunt Team
 
TURBS's Avatar
 
Join Date: Aug 2011
Location: Iowa
Posts: 34,337
Quote:
Originally Posted by Blazincfd View Post
Just heard from the service person. He said that we have to have battery switch disconnected or the LP detector will drain it in 24 hours. I think my money is still on the converter. Why else would the lights dim and nothing work during the day. Thank you your advice. When we get it back I am going to look at the convert for the numbers to see what we can replace it with.
DEFINITELY replace it with a progressive dynamics converter if you find yours is bad.

If you have the room get a 9200 series 60 amp deck mount with charge wizard!

Yours is likely a 55 amp

TURBS
08 duramax tuned n modded, 32bhok Sabre
2015 camping "4 nights"
__________________
TURBS is offline   Reply With Quote
Old 05-06-2015, 04:39 PM   #30
Junior Member
 
Join Date: May 2015
Posts: 9
Thanks. I looked the one you suggested. I was trying to figure out what we needed. We have 50AMP so the 55 is what we would need?
__________________

__________________
Blazincfd is offline   Reply With Quote
Reply

Tags
battery

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 08:23 PM.