Reply
 
Thread Tools Display Modes
Old 04-10-2015, 08:33 AM   #51
Senior Member
 
Join Date: Jul 2009
Location: Warsaw,NC
Posts: 4,284
Quote:
Originally Posted by Blackhat6mike View Post
My inverter cost me $1,000. You guys are scaring me!!!

What kind have you got and how many watts


Sent from my iPhone using Forest River Forums
__________________

__________________
2015 Cedar Creek 32RL
2012 Silverado 3500HD SRW
http://www.forestriverforums.com/for...ignhavefun.gif
spock123 is online now   Reply With Quote
Old 04-11-2015, 08:30 PM   #52
Senior Member
 
Join Date: Jan 2015
Posts: 119
Well I've been trying to copy and post the diagram Cedar Creek sent me as the proper way to connect the 4 6 volt batteries. Cannot get it to copy over. Any I just got thru replacing my inverter. Cedar Creek sent me a knew one as the old one had a internal fault code. All done and working good now.
__________________

__________________
2015 Cedar Creek 36 CKTS

2016 Ford F350 DRW
2016 Harley Davidson Ultra Classic Low
rick03hd is offline   Reply With Quote
Old 05-22-2016, 07:52 PM   #53
Senior Member
 
Coolharts's Avatar
 
Join Date: Sep 2014
Location: Siler City,NC
Posts: 268
My Surveyor came with a 1000 Watt inverter for the fridge, the first trip out it did not work, I found out the 12 Volt batteries were wired wrong. To get by I hooked everything to one battery. It seemed to work ok.

I wired the batteries in parallel today and the inverter does not come on, I switched back to one battery and still no go. I checked all of the connections, the 100 AMP fuse and the only light that comes on is the AC power light when connected to shore power. Nothing at all happens on the display, I have disconnected AC and DC power to reset. Any suggestions? I think the unit is bad.
__________________
2017 Surveyor 33RETS with Residential Refrigerator and Inverter
2005 Ford Excursion 6.0L 2WD
Nights Camped 2016 27
Nights Camped 2017 29
Coolharts is offline   Reply With Quote
Old 05-22-2016, 10:11 PM   #54
Senior Member
 
Join Date: Jan 2013
Posts: 1,477
Did you check your battery voltage? Silly question but...
__________________
2016 Siverback 33IK
2015 Ford F-250 Lariat 6.7L V8 Diesel 4WD Super Cab

"If you don't know where you are going, any road will get you there."
dalford is offline   Reply With Quote
Old 05-22-2016, 10:25 PM   #55
Senior Member
 
Coolharts's Avatar
 
Join Date: Sep 2014
Location: Siler City,NC
Posts: 268
Yes, both batteries were at 13. I also disconnected shore power and operated the slides using the batteries just to be sure everything was wired correctly.
__________________
2017 Surveyor 33RETS with Residential Refrigerator and Inverter
2005 Ford Excursion 6.0L 2WD
Nights Camped 2016 27
Nights Camped 2017 29
Coolharts is offline   Reply With Quote
Old 05-23-2016, 07:17 PM   #56
Senior Member
 
Join Date: Jul 2009
Location: Warsaw,NC
Posts: 4,284
Quote:
Originally Posted by Coolharts View Post
Yes, both batteries were at 13. I also disconnected shore power and operated the slides using the batteries just to be sure everything was wired correctly.

I would check all my connections again. Just to make sure.


Sent from my iPhone using Forest River Forums
__________________
2015 Cedar Creek 32RL
2012 Silverado 3500HD SRW
http://www.forestriverforums.com/for...ignhavefun.gif
spock123 is online now   Reply With Quote
Old 05-23-2016, 07:31 PM   #57
Senior Member
 
jacknife's Avatar
 
Join Date: Aug 2013
Location: Ramona Ca
Posts: 206
The invertor may be gone. Can you plug something else 110 into the same recepticle as the fridge just to see if it works or put a meter on it.
__________________
jacknife is offline   Reply With Quote
Old 05-25-2016, 08:46 PM   #58
Senior Member
 
Coolharts's Avatar
 
Join Date: Sep 2014
Location: Siler City,NC
Posts: 268
I contacted WFCO Electronics tech support and they had me diagnose the unit, it is bad. I submitted a form for a warranty replacement and it should be here tomorrow. So far I am impressed with their service!
__________________
2017 Surveyor 33RETS with Residential Refrigerator and Inverter
2005 Ford Excursion 6.0L 2WD
Nights Camped 2016 27
Nights Camped 2017 29
Coolharts is offline   Reply With Quote
Old 05-25-2016, 10:17 PM   #59
Senior Member
 
Join Date: Jan 2015
Location: Englewood FL
Posts: 1,587
Quote:
Originally Posted by Coolharts View Post
I contacted WFCO Electronics tech support and they had me diagnose the unit, it is bad. I submitted a form for a warranty replacement and it should be here tomorrow. So far I am impressed with their service!
Great support. Now if most of the people on this forum were as impressed with their converters they would be doing a lot better.
__________________

2015 335DS
ScottBrownstein is offline   Reply With Quote
Old 05-26-2016, 08:16 AM   #60
Senior Member
 
Join Date: Mar 2014
Posts: 1,748
Quote:
Originally Posted by Coolharts View Post
I contacted WFCO Electronics tech support and they had me diagnose the unit, it is bad. I submitted a form for a warranty replacement and it should be here tomorrow. So far I am impressed with their service!
Can you walk us through the test procedure, so if it happens to another WFCO owner, he can get ahead of it. Thanks
__________________

__________________
Still Kickin is offline   Reply With Quote
Reply

Tags
inverter

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 06:44 PM.