Reply
 
Thread Tools Display Modes
Old 03-13-2015, 09:30 PM   #1
Senior Member
 
Join Date: Aug 2014
Location: Marshalltown Ia
Posts: 130
Refrigerator in Silverback

I have had a 2014 31RK for almost a year. The frig has never worked right from the beginning. Have had it at dealers twice right away for several thing. Told nothing wrong. Have talked to Jeff Holmes several times. Was told he would look into it.. Gave me the name of someone to check it out. He is very good and has fixed several things the dealer was to lazy to fix. So far has insulated the frig. No change. Now running a five day test. So far no change. I told Jeff I wanted a new frig NOW. Have heard nothing.
I have talked to Dometic and nothing. I downloaded the manual for the frig. Have been repeatedly told it is to warm up at night and then cool off and the manual says it takes 120 minutes. Mine takes between 12 and 48 hours to cool off again.
Got mad at dealer when they reminded me my 1 year warranty is about up. I bought the extra year warranty no thanks to them, never even told me about it. Told them where to go.
Any suggestions would be greatly appreciated.
__________________

__________________
Silverback Iowan is offline   Reply With Quote
Old 03-18-2015, 12:42 AM   #2
Senior Member
 
Join Date: Aug 2014
Location: Marshalltown Ia
Posts: 130
Dometic is sending 2 mother boards to fix the frig. Thank You Finally
__________________

__________________
Silverback Iowan is offline   Reply With Quote
Old 03-18-2015, 11:22 PM   #3
Senior Member
 
Join Date: May 2010
Posts: 146
do you have to put the mother boards in? or does the warranty allow dealer or mobile rv repair to put it in? wondering ...

thanks for info.

bill & jodi
__________________
stormy2000 is offline   Reply With Quote
Old 03-19-2015, 01:26 AM   #4
Senior Member
 
Join Date: Aug 2014
Location: Marshalltown Ia
Posts: 130
An RV repair man is doing it. It is paid for under warranty except for a service call charge. Hope this fixes the problem. Has not worked right since we got it new a year ago.
__________________
Silverback Iowan is offline   Reply With Quote
Old 03-19-2015, 03:35 AM   #5
Senior Member
 
Join Date: May 2010
Posts: 146
Ok hope all goes good. .we have 31rk sb also.. so was curious on fix. Tks again
Bill & jodi
__________________
stormy2000 is offline   Reply With Quote
Old 03-20-2015, 01:58 PM   #6
Member
 
Kampnnit's Avatar
 
Join Date: Jul 2013
Posts: 37
My frig did not work good for the get go. Took it to the dealer and said it was fixed, WRONG. Took it back and said it was fixed again, WRONG again. They had a temp gage in the frig and show me the temp was 20 degrees on the inside. They were right, 20 degrees C not 20 degrees F. left it there and they finally put in a new control board which fixed it.
In my research I discovered there is supposes to be an air baffle, as per the installation manual, at the top of the frig to direct the warm air out the top vent, frig is in the slide out. Well that was not there. The baffle is supposes to be part of the factory install. All the dealer did was stuff insulation on top of the frig. I make my own baffle after I got it home. All is good now. It has been working well for over a year now. Needless fired them.
__________________
Kampnnit is offline   Reply With Quote
Old 03-20-2015, 09:55 PM   #7
Senior Member
 
Join Date: Aug 2014
Location: Marshalltown Ia
Posts: 130
Yes Putting insulation on top was another thing they have tried. Will have to check on the baffle when we get home. But thanks for the info.
__________________
Silverback Iowan is offline   Reply With Quote
Old 03-23-2015, 08:39 AM   #8
Member
 
Kampnnit's Avatar
 
Join Date: Jul 2013
Posts: 37
Hope the picture will give you an idea on what I did. I used some thin sheet metal to create the baffle. Sealed it with aluminum tape used in HVAC. I also repositioned the thermo switch used to power the small computer style fan that draws air from the bottom and sends it out the top. I did this so it would engage the fan sooner. It was mounted on the fin to the left of there it is now.
Attached Thumbnails
Click image for larger version

Name:	Baffle.jpg
Views:	132
Size:	279.6 KB
ID:	71989  
__________________
Kampnnit is offline   Reply With Quote
Old 03-23-2015, 07:15 PM   #9
Senior Member
 
Join Date: Aug 2014
Location: Marshalltown Ia
Posts: 130
Thanks for the info. I should know in a few days if the 2 boards they put in are working. Was told if this did not work would get a new frig. Hope it works.
__________________
Silverback Iowan is offline   Reply With Quote
Old 04-01-2015, 05:58 PM   #10
Senior Member
 
Join Date: Aug 2014
Location: Marshalltown Ia
Posts: 130
The 2 boards they put in my Frig are working as of now any way. So glad to have it fixed. Thank you Mark for sticking with it till the problem was found. No one else was interested in finding a problem. They were to busy telling me I did not know what I was talking about that it worked just fine. He worked with Dometic till it was fixed. And it did not work from the 1st time we used it. Only took a year.
__________________

__________________
Silverback Iowan is offline   Reply With Quote
Reply

Tags
refrigerator

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 05:41 AM.