Thread Tools Display Modes
Old 07-26-2011, 11:55 AM   #1
Junior Member
Join Date: Jul 2011
Posts: 1
Question Refrigerator ventilation problem

Would like to find out if anyone else is having the same problem as we are. Purchased a new Silverback 29RE four weeks ago, the refrigerator has not operated properly since day one. Even took it back to the dealer for them to diagnose and fix. They got the Cedar Creek engineers involved, and came up with the solution of installing a second fan. Got it back home only to discover that it is still not working properly. The refrigerator is in a slide, so there is no roof vent, plus the factory installed the upper vent too low (per the Dometic instruction booklet). Anyway, after this long history, has anyone had this problem? If so, did you get it resolved and how? Any input would be greatly appreciated, we haven't even got to use it frustrating.
CBnOK is offline   Reply With Quote

refrigerator, slide, vent

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Virginia Campgrounds

Reviews provided by is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 05:41 PM.