Reply
 
Thread Tools Display Modes
Old 05-19-2015, 08:55 PM   #11
Junior Member
 
Join Date: Mar 2015
Posts: 10
OK thanks everyone I've had this rv for about a year now with no help from the dealer... I'm just trying to figure this thing out... Other than that I love the unit.
__________________

__________________
zking74 is offline   Reply With Quote
Old 05-19-2015, 09:12 PM   #12
Senior Member
 
hkreck's Avatar
 
Join Date: Apr 2012
Location: Iowa
Posts: 1,190
Don't know if it would help your problem, but might try a cyclone sewer vent. It's suppose to pull and odors up out of your black tank. Attaches to the top of the sewer vent, takes about 15 minutes to install. Good luck
__________________

__________________
Henry & Tena
2013 Solera 24S
The Great Escape
hkreck is online now   Reply With Quote
Old 05-19-2015, 09:16 PM   #13
Junior Member
 
Join Date: Oct 2013
Posts: 5
You might have some Magic Plumbing like I had !! Pipe in wall was not glued together...after 5000 miles of bumps it came apart.
__________________
Redbeard2 is offline   Reply With Quote
Old 05-19-2015, 09:22 PM   #14
Junior Member
 
Join Date: Oct 2013
Posts: 5
like this
Attached Thumbnails
Click image for larger version

Name:	IMG_20150402_142709.jpg
Views:	89
Size:	261.1 KB
ID:	77492  
__________________
Redbeard2 is offline   Reply With Quote
Old 05-19-2015, 10:31 PM   #15
Senior Member
 
Join Date: Nov 2013
Location: crete,il /texas
Posts: 384
and where was this "majic plumbing "at?
__________________
Big Bill is offline   Reply With Quote
Old 05-19-2015, 10:35 PM   #16
Junior Member
 
Join Date: Oct 2013
Posts: 5
look for the vent on the roof, then open the wall below inside unit. Surprise!! Plumbing that is not glued together.
__________________
Redbeard2 is offline   Reply With Quote
Old 05-20-2015, 05:45 AM   #17
Junior Member
 
Join Date: Mar 2015
Posts: 10
Lol I love surprises..... Thanks again everyone
__________________
zking74 is offline   Reply With Quote
Old 05-24-2015, 07:22 AM   #18
CCRVOC
 
rockfarmer's Avatar
 
Join Date: Aug 2006
Location: Crestwood, KY
Posts: 46
A friend had the same problem. discovered that the vent pipe was installed too low in the black tank and the when the level in the tank got above the pipe, there was no place for the air (and odors) to vent to. Another symptom he noticed was that when flushing the toilet, it would "burb" air when flushing.
__________________
Jerry and Irene
2015 Chevy High Country 3500 CC/LB D/A -- 2009 Cedar Creek 34 TSA
2012 - nights camped - 153; miles on CC - 14779
2013 - nights camped - 88; miles on CC - 9066
2014 - nights camped - 57; miles on CC - 5263
2015 - nights camped - 95; miles on CC - 11179
rockfarmer is offline   Reply With Quote
Old 05-24-2015, 08:18 AM   #19
Junior Member
 
Join Date: Mar 2015
Posts: 10
Great thanks rockfarmer sounds exactly what mine is doing
__________________

__________________
zking74 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 05:38 PM.