Thread Tools Display Modes
Old 07-18-2014, 04:57 PM   #1
Junior Member
Join Date: Jul 2014
Posts: 1
silverback 29RE hydraulics

Hey everyone, I have an issue and want to know if anyone else has the same issue ? We have a 2014 Cedar Creek Silver back 29RE. For the second time now the hydraulic pump motor is leaking fluid. First time happened after a local trip in April, the dealer replaced the unit. This second time we just got back from Lake George and I noticed an issue with the movement of the slides an sure enough I have fluid leaking from the same area of t. he pump motor. Any other cedar creek owners have a similar issue. Thank you for any comments.
jmag is offline   Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Virginia Campgrounds

Reviews provided by is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 04:00 AM.