Reply
 
Thread Tools Display Modes
Old 09-06-2015, 01:35 PM   #41
Senior Member
 
Join Date: May 2014
Location: Halifax Nova Scotia Canada
Posts: 571
Quote:
Originally Posted by traeger3 View Post
Found out that for some reason we had been missing a 50 amp circuit breaker behind the buss bar. It only had 2 and should have had 3 so we didn't have a complete connection. Looked everywhere but couldn't find the breaker laying around. Don't know what happened to it but all is great now. Smoky Mountains here we come.
That is very odd!!!!I have never heard of any more that "two" 30 or 50 amp main breakers......There should be an electrical schematic on the door of the fuse panel showing the mains......Are you sure that the so called 3rd breaker is not a 15 or 20 amp distribution breaker??????..............J
__________________

__________________
Jim in Halifax is offline   Reply With Quote
Old 09-07-2015, 10:49 AM   #42
Junior Member
 
traeger3's Avatar
 
Join Date: Jan 2015
Posts: 28
Purchased used,have no idea.
__________________

__________________
traeger3 is offline   Reply With Quote
Old 09-07-2015, 10:50 AM   #43
Junior Member
 
traeger3's Avatar
 
Join Date: Jan 2015
Posts: 28
Sure, looked at another Silverback at a campground near us.
__________________

__________________
traeger3 is offline   Reply With Quote
Reply

Tags
battery, slide, slide out

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 03:49 AM.