Reply
 
Thread Tools Display Modes
Old 07-05-2015, 08:47 AM   #1
Junior Member
 
Join Date: Apr 2014
Posts: 6
Generator clicks

Generator won't start by control panel switch or start on generator itself.
Clicks like battery low but control panel says batteries fully charged.
Any ideas?
__________________

ty20657 is offline   Reply With Quote
Old 07-05-2015, 09:15 AM   #2
Senior Member
 
B and B's Avatar
 
Join Date: Jun 2013
Location: Wilmot Twp, Ontario, Canada
Posts: 9,139
Sounds like a bad connection, check for corrosion on battery terminals and the starter relay/ starter itself.
If this is not the problem rap the starter with dead blow object. Could be a and starter brush or stuck commutator. I have done this t everything from Pinto to a Detroit Diesel 100 kw generator.
__________________

__________________
2017 Heartland Bighorn 3575 Elite with Reese Sidewinder
2016 Ford F 350 SD PS 6.7 SRW Crew Pucks and Reese 18 K Elite

2013 Rockwood 8289WS 2012 Rockwood 2703 SS TT 2007 Golden Falcon 38FLA PM 1983 Corsair 21RB
2015 Ford F250 PS '13 F150 3.5 Eco '09 F150 5.4 l 1987 Merc Grand Marq 1982 Ford E250 CW
B and B is offline   Reply With Quote
Old 07-05-2015, 09:54 AM   #3
Senior Member
 
StephanFR3's Avatar
 
Join Date: Aug 2013
Location: Florida
Posts: 486
They are 2 way switches are you hearing the priming clicks?
StephanFR3 is offline   Reply With Quote
Old 07-05-2015, 10:45 AM   #4
Junior Member
 
Join Date: Apr 2014
Posts: 6
Yes to click noise when hitting start switch on Gen and at control panel. Main drive engine starts fine.
ty20657 is offline   Reply With Quote
Old 07-05-2015, 11:27 AM   #5
Senior Member
 
StephanFR3's Avatar
 
Join Date: Aug 2013
Location: Florida
Posts: 486
Just to be clear. You are pressing the switch to prime till it slows or stops, then pressing the switch the other direction to start?
StephanFR3 is offline   Reply With Quote
Old 07-05-2015, 11:29 AM   #6
Senior Member
 
StephanFR3's Avatar
 
Join Date: Aug 2013
Location: Florida
Posts: 486
I know what I am referring to should seem obvious, but always check the simple things first.
StephanFR3 is offline   Reply With Quote
Old 07-05-2015, 11:38 AM   #7
Senior Member
 
StephanFR3's Avatar
 
Join Date: Aug 2013
Location: Florida
Posts: 486
FYI I am in very hot florida and have seen mine twice and another RV have generators that would not run due to heat stopped parked in hot parking lot. They were I believe vapor locked. Let cool but still wouldn't run. Held the prime switch for a couple minutes till it stopped and it ran fine after that. The guy with the other RV thought I was a genus when I saw him struggling with the same thing. And I walked over and fixed his generator in 2 minutes.
StephanFR3 is offline   Reply With Quote
Old 07-05-2015, 06:02 PM   #8
Junior Member
 
Join Date: Apr 2014
Posts: 6
Thanks stephan fr3
ty20657 is offline   Reply With Quote
Old 07-05-2015, 07:22 PM   #9
Senior Member
 
fpo1123's Avatar
 
Join Date: Oct 2014
Location: Maurertown VA
Posts: 153
Mine did that and I just hit the battery switch by the front door and went back to the start button and primed it and then hit the start and no problem. That happened twice.
__________________

MSG (Ret)
U.S. Army
Active-duty 66-92
2015 FR3 30DS
fpo1123 is offline   Reply With Quote
Old 07-06-2015, 12:19 AM   #10
Junior Member
 
Join Date: Apr 2014
Posts: 6
Thanks fpo1123 will try and let you know
__________________

ty20657 is offline   Reply With Quote
Reply

Tags
generator

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Featured Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 12:31 PM.