Reply
 
Thread Tools Display Modes
Old 11-22-2015, 06:54 AM   #1
Motoring
 
grotto69's Avatar
 
Join Date: Sep 2013
Posts: 254
Kitchen Sink Stopped Working

Sometime between cutting over between Water Pump and City Water, the kitchen sink no longer comes on

It was working two weeks ago and I Have not changed anything with the valves below by the water heater.

I suspect my water pump is no longer working, I'm not hearing it any more. Does water to the kitchen sink flow differently on city water than the rest of the coach?

Anyone seen this before? I was working on it last night but had to stop when the propane started leaking into the coach.

Steve
__________________

__________________
grotto69 is offline   Reply With Quote
Old 11-22-2015, 07:19 AM   #2
Senior Member
 
dan-nickie's Avatar
 
Join Date: Feb 2014
Location: Dallas TX
Posts: 1,506
Probably the little screen in the end of the faucet.
Unscrew the end of the faucet and clean the screen.
__________________

__________________
Dan
2014 Berkshire 390RB-60
dan-nickie is offline   Reply With Quote
Old 11-22-2015, 07:45 AM   #3
Senior Member
 
Join Date: May 2014
Location: Newfoundland & Labrador
Posts: 122
Hi. It was working OK while using your pump and fresh water tank but not when switched over to city water, correct? I'm assuming that you have no water to the vanity, shower, etc... either?
Couple of questions:
What kind of trailer do you have?
Can you confirm that you have sufficient water pressure on your city water hose? I had a similar problem two years ago caused by a faulty water pressure regulator I had added where my hose connects to the park city water supply. Also, no kinks in the hose?
When was the last time it was working OK on city water? If it's been a while, the check valve on the city water inlet may be stuck preventing the water from entering the trailer.
__________________
2010 Wildwood XLite 26BHXL
2013 Ram Outdoorsman 5.7l
Ontherock is offline   Reply With Quote
Old 11-22-2015, 08:07 AM   #4
Senior Member
 
Join Date: May 2014
Location: Newfoundland & Labrador
Posts: 122
Also, your water pump doesn't work when on city water - it doesn't have to. Think about your water pressure at home. The water pressure in your house is provided by the town/city water supply (if you're connected to the town/city supply and not on a well with a pump) so a pump is not needed. Same thing in your trailer. As long as you are on city water, the water pressure in your trailer is provided by the town/city/park water system.
__________________
2010 Wildwood XLite 26BHXL
2013 Ram Outdoorsman 5.7l
Ontherock is offline   Reply With Quote
Old 11-22-2015, 01:37 PM   #5
TARVIDSON
 
Join Date: Jan 2015
Location: Missoula, Mt
Posts: 107
If your water doesn't come out that sink on either pump or city but does others probably the screen as mentioned. If your pump motor is not making noise, check power to the pump 12V DC, if you have power to the pump and it doesn't work, replace the pump, no power, trace issue from there, fuse, switch, wiring etc.
__________________
TARVIDSON is offline   Reply With Quote
Old 11-22-2015, 01:48 PM   #6
Senior Member
 
RSchleder's Avatar
 
Join Date: Apr 2014
Location: Iowa
Posts: 1,277
Also, as a heads up, although this doesn't sound like your issue, there is also a small straining screen on the bottom of the water pump that can also get clogged!
__________________
Days camping (2016)----181 days
Days camping (2017) --- 82 days
2016 Wildcat MAXX 28RKX (33' TT), 2007 13' Scamp
2015 Ram Laramie Hemi, w/air suspension
30 years RV'ing
12 different RV's
RSchleder is offline   Reply With Quote
Old 11-22-2015, 05:58 PM   #7
Junior Member
 
Join Date: Aug 2015
Location: Tipp City, Ohio
Posts: 19
Water pump doesn't run when hooked to City water.
__________________
Wesley1249 is offline   Reply With Quote
Old 11-22-2015, 06:25 PM   #8
Senior Member
 
BobHanke's Avatar
 
Join Date: Sep 2013
Location: West Des Moines, IA
Posts: 270
If only the kitchen sink is involved, both hot and cold are affected and you have a pull out faucet hose, loosen the set screw that holds the hose to the main assembly, take it off and check for debris at the end of the hose.
__________________
"Lurch" = Georgetown 2011 330TS
Jeep 2016 Cherokee
Pilot = Bob
Navigator = Xiangbing
Crew = Shikibu
BobHanke is offline   Reply With Quote
Old 11-22-2015, 07:07 PM   #9
Motoring
 
grotto69's Avatar
 
Join Date: Sep 2013
Posts: 254
Hi All,

It was the screen being clogged at the kitchen sink. I ended up replacing it for 6 bucks with on the swivels and does spray too, just because I like those features.


We are back in business and relaxing with family, the good life.

I turned off city water and the pump is working too

Thanks all on this boar!!

Steve
__________________

__________________
grotto69 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 04:51 AM.