Thread Tools Display Modes
Old 06-20-2015, 10:10 AM   #51
Join Date: Nov 2014
Posts: 70
I had the same problem. The factory puts either the AC on the main house fuse or on its own but next to the main fuse, depending on your year. Either way, the heat from this causes the breaker to trip.

FR put my AC on its own fuse and moved it to the opposite side of the box from the main and no more problems.

2015 FR3 30DS

Sent from my iPhone using Forest River Forums

MaltnHops is offline   Reply With Quote
Old 06-20-2015, 07:05 PM   #52
AngioTech55's Avatar
Join Date: Mar 2015
Location: Redlands, Ca
Posts: 56
I had the same issue last weekend and all I did was break out the 50amp whip and never had another issue

AngioTech55 is offline   Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Virginia Campgrounds

Reviews provided by is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 01:24 PM.