Reply
 
Thread Tools Display Modes
Old 09-18-2012, 09:54 PM   #1
Junior Member
 
Join Date: Sep 2012
Posts: 2
28A+ with power issue

I purchased my first tt and have a small problem. I got my camper home and the only thing that works on battery power is the slides. I've got no lights or radio unless I plug into shore power or my truck. Need a little help.
__________________

__________________
family truckster is offline   Reply With Quote
Old 09-18-2012, 10:14 PM   #2
Phat Phrog Stunt Team
 
TURBS's Avatar
 
Join Date: Aug 2011
Location: Iowa
Posts: 34,337
check the fuses in the distribution panel ?
circuit breaker under the hitch ?
__________________

__________________
TURBS is offline   Reply With Quote
Old 09-18-2012, 10:25 PM   #3
Junior Member
 
Join Date: Sep 2012
Posts: 2
I did reset all the breakers under the fridge. I will have to look closer for the one on the hitch. Thanks.
__________________
family truckster is offline   Reply With Quote
Old 09-18-2012, 10:33 PM   #4
Phat Phrog Stunt Team
 
TURBS's Avatar
 
Join Date: Aug 2011
Location: Iowa
Posts: 34,337
yes look under the hitch back on the frame there is a or should be a circuit breaker thats reset able. if its not reset able it may be bad .

someone with a 28a may be better knowledgable about your unit .


turbs
__________________
TURBS is offline   Reply With Quote
Reply

Tags
28a

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 03:30 PM.