Reply
 
Thread Tools Display Modes
Old 07-17-2013, 11:30 AM   #11
Member
 
NorminN.B.'s Avatar
 
Join Date: Oct 2010
Location: Saint John, N.B. Canada
Posts: 68
thanks, Turbo, thats the handle, only mine is white, and on the side, instead of on the front of the arm. lol I must be the only one that cant get them to engage. My trailer is an 09, they should not be worn out yet.
__________________

__________________
NorminN.B. is offline   Reply With Quote
Old 07-17-2013, 11:45 AM   #12
Phat Phrog Stunt Team
 
TURBS's Avatar
 
Join Date: Aug 2011
Location: Iowa
Posts: 34,337
Quote:
Originally Posted by NorminN.B. View Post
thanks, Turbo, thats the handle, only mine is white, and on the side, instead of on the front of the arm. lol I must be the only one that cant get them to engage. My trailer is an 09, they should not be worn out yet.
Those pins stick.
A little lube would help.
__________________

__________________
TURBS is offline   Reply With Quote
Old 07-17-2013, 03:51 PM   #13
Member
 
NorminN.B.'s Avatar
 
Join Date: Oct 2010
Location: Saint John, N.B. Canada
Posts: 68
I'll try some lube the next time I'm at the trailer. Thanks.
__________________

__________________
NorminN.B. is offline   Reply With Quote
Reply

« Vin | toggle switch »
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 03:30 PM.