Reply
 
Thread Tools Display Modes
Old 04-14-2013, 11:18 PM   #1
Junior Member
 
Jehyatt00's Avatar
 
Join Date: Dec 2012
Posts: 9
Battery usage or lack of none

I have tried to turn on items in my 2012 Grey Wolf 26 BH without shore power and nothing works. Instrument panel says battery is full and its connected to power year round. Any suggestions? Thanks in advance.
__________________

__________________
Jehyatt00 is offline   Reply With Quote
Old 04-14-2013, 11:27 PM   #2
Site Team - Lou
 
Herk7769's Avatar
 
Join Date: Oct 2009
Location: South Eastern PA
Posts: 21,155
Nothing AC (like microwave or TV) or nothing at all - DC (lights, radio, furnace, fridge)?
__________________

__________________

Lou and Laura with Bella - German Short Hair Pointer
2008 GMC Sierra 2500HD Crewcab SB Allison Duramax
2010 Flagstaff 8526RLWS - Superglide 3300
HAM CALLSIGN - KC3FFW
Herk7769 is offline   Reply With Quote
Old 04-14-2013, 11:29 PM   #3
Moderator Emeritus
 
Dave_Monica's Avatar
 
Join Date: Sep 2007
Location: Ontario, Canada
Posts: 4,329
Best to check the battery voltage...should be around 12.7 V if fully charged and 13.5V if plugged into shorepower and the converter is charging. If you have no 12V lighting without shorepower the battery is dead or disconnected. If you don't have a battery disconnect switch, check for an in-line fuse or resettable circuit breaker close to the battery.
__________________


Nights camped in 2013 - 55, 2014 - 105, 2015 - 63
Dave_Monica is offline   Reply With Quote
Old 04-14-2013, 11:29 PM   #4
Junior Member
 
Jehyatt00's Avatar
 
Join Date: Dec 2012
Posts: 9
All I checked were lights, vent fan and stereo. Nothing turns on.
__________________
Jehyatt00 is offline   Reply With Quote
Old 04-14-2013, 11:33 PM   #5
Junior Member
 
Jehyatt00's Avatar
 
Join Date: Dec 2012
Posts: 9
Thanks Dave ill check that tomorrow for sure. Been like this since I purchased it in October. But just now getting around to trying to figure it out. My other TT works fine ?
__________________
Jehyatt00 is offline   Reply With Quote
Old 04-15-2013, 12:14 AM   #6
Moderators' Assistant
 
bikendan's Avatar
 
Join Date: Jan 2007
Location: Camano Island, Washington
Posts: 13,247
was the battery moved or replaced?

there's a small resettable circuit breaker along the tongue, that gets tripped if the wires are crossed. there's a black button on it that you need to push to reset it.
__________________
Dan-Retired Firefighter/EMT
Shawn-Musician/Entrepreneur/Wine Expert
and Zoe the Wonder Dog(R.I.P.)
2016 PrimeTime TracerAIR 255, pushing a 2014 Ford F150 4x4 3.5 Ecoboost w/Max Tow Package
Equalizer WDH and Prodigy BC
bikendan is online now   Reply With Quote
Old 04-15-2013, 12:40 AM   #7
Senior Member
 
John McClain's Avatar
 
Join Date: Jan 2013
Location: Ventura
Posts: 166
Did you turn the main on !!
__________________
F-250 . stealth 3210 solar pannels, fantastic fans. and life line batteries
John McClain is offline   Reply With Quote
Old 04-15-2013, 07:17 AM   #8
Phat Phrog Stunt Team
 
TURBS's Avatar
 
Join Date: Aug 2011
Location: Iowa
Posts: 34,336
Quote:
Originally Posted by bikendan View Post
was the battery moved or replaced?

there's a small resettable circuit breaker along the tongue, that gets tripped if the wires are crossed. there's a black button on it that you need to push to reset it.
X2
__________________
TURBS is offline   Reply With Quote
Old 04-15-2013, 07:06 PM   #9
Junior Member
 
Jehyatt00's Avatar
 
Join Date: Dec 2012
Posts: 9
Quote:
Originally Posted by bikendan View Post
was the battery moved or replaced?

there's a small resettable circuit breaker along the tongue, that gets tripped if the wires are crossed. there's a black button on it that you need to push to reset it.
You were correct. Reset the breaker and tighten down the battery connections and works as its advertised. Thanks for all your help.
__________________
Jehyatt00 is offline   Reply With Quote
Old 04-15-2013, 07:08 PM   #10
Junior Member
 
Jehyatt00's Avatar
 
Join Date: Dec 2012
Posts: 9
Quote:
Originally Posted by John McClain View Post
Did you turn the main on !!
The main circuit panel breaker is on if that's what your referring to John. I'm new to this so if that's not it, I'm at a total loss.
__________________

__________________
Jehyatt00 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 03:55 PM.