Reply
 
Thread Tools Display Modes
Old 10-24-2012, 06:09 PM   #1
Member
 
NorminN.B.'s Avatar
 
Join Date: Oct 2010
Location: Saint John, N.B. Canada
Posts: 68
Cherokee Furnace

The furnace in my Cherokee 39L stopped working, the first day of deer season. It is the F30. It would run about 30 seconds then shut off. I took the furnace out and took it to the dealer to check out. There was a chaffed wire in the bottom of the furnace, where the heat comes out, shorting out and stopping the sparking process and shutting it down. If anyone has a problem with their furnace and is taking it out for repair, you might want to check this wire and isolate it from the metal. I used hi heat gasket silicone. There was also a screw missing from the rear brace on the fan motor, probably causing more vibration than usual. I don't think there was ever a screw in it. Also it is a very poor place to run the wires.
__________________

__________________
NorminN.B. is offline   Reply With Quote
Old 10-25-2012, 12:41 PM   #2
Senior Member
 
rotorhead1250's Avatar
 
Join Date: Dec 2011
Location: Albuquerque
Posts: 277
Good info to pass along!
__________________
Matt & Kathie
2017 Grey Wolf 27RR
rotorhead1250 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 08:37 PM.