Thread Tools Display Modes
Old 07-09-2013, 11:23 PM   #1
Junior Member
Join Date: Jul 2013
Posts: 2
Concertone zx600

Hi, I have a concertone zx600 and it came with one television. It is mountable in either the living room or the bedroom. Both locations have a video hookup as well as a 12v hookup. The only issue is, when I hook it up in the bedroom it seems as if there is no power. Is this just a fuse somewhere? Also, is it at all possible to swap the 12v tv out for a larger 110v? I know I may have to run power and everything but is it worth it?

Am I beating a dead horse? Should I just bite the bullet and get a whole new system? It sounds fine, but pretty stressful.
tyrelmoe is offline   Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Virginia Campgrounds

Reviews provided by is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 03:33 PM.