Thread Tools Display Modes
Old 08-15-2012, 07:21 PM   #1
TeresaInCAL's Avatar
Join Date: Aug 2012
Location: California foothills
Posts: 423
Fresh Water Tank Problems

Oh, you also might have someone (you trust), check the strapping for the fresh water tank. Mine snapped the first year. Turns out they only used a very thin metal strap similar to hot water tank strapping (with the holes). My RV guy welded a bar under to hold it properly.

TeresaInCAL is offline   Reply With Quote
Old 08-31-2012, 12:57 PM   #2
Junior Member
Join Date: Aug 2012
Posts: 6
On another issue the fresh water tank drain valve was directly above the rear axle and upon shipment from the factory to the dealer the axle busted the fresh water tank and was leaking Good thing the dealer fills everything with water and gives it a checkout before you leave. I am the one that found this only because the dealer still had some water left in the tank they had to build an offset and rerun the hose to the pump to clear the axle. Besides replacing the tank Nice huh??!!Also the straps that hold the tank in are really inadequate and I put in a few more stronger ones to hold things in place. Seems like a lot of work by the owner so everybody look at your tanks!

Hemi 4 ME is offline   Reply With Quote
Old 08-31-2012, 08:27 PM   #3
Senior Member
Rsgtivr6's Avatar
Join Date: May 2012
Location: Champlin, MN
Posts: 433
About the FW tank, mine was cracked from factory as well (found pre-PDI when I put in a request to check for the infamous missing vent line) and they replaced it before I picked it up. Cost me another week of waiting, but didn't need it that week anyways.
TV: '06 Ram 1500 SLT QCSB Hemi 4x4
TT: '12 Grey Wolf 27BHKS
Tow Acc: Tekonsha P3 BC, Curt round bar WDH w/sway control, CIPA custom fit tow mirrors
'12: 27
Rsgtivr6 is offline   Reply With Quote
Old 09-04-2012, 07:11 AM   #4
Junior Member
Join Date: Aug 2012
Posts: 6

You mean to tell me there is suppose to be a vent line from the factory?? I put a tube on myself thinking this was a pretty shoddy way of letting the air out of the tank when you fill it. Thought there was suppose to be something there because I thought that was a terrible way of letting dirt and debris into the tank.
Hemi 4 ME is offline   Reply With Quote
Old 09-04-2012, 08:01 AM   #5
Senior Member
Big Dawg's Avatar
Join Date: Jan 2011
Location: Columbus, Ohio
Posts: 533
Yes, they were supposed to have installed it. I had the same problem on mine. I went and bought the supplies and did it myself.
2004 Chevy Avalanche Z66 W/Transmission Cooler
2011 Grey Wolf 28BH
Blue Ox Sway Pro WDH
2 Beagles (Snoopy & Dexter)

Big Dawg is offline   Reply With Quote
Old 09-04-2012, 08:34 AM   #6
Junior Member
Join Date: Aug 2012
Posts: 6
What Did you use for the end of the hose? some kind of difuser stone to let air out but keep debris from getting in? And how far did you run the hose out somewhere on the frame rail?

Hemi 4 ME is offline   Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Virginia Campgrounds

Reviews provided by is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 01:42 AM.