Reply
 
Thread Tools Display Modes
Old 06-29-2015, 12:29 PM   #1
Member
 
Join Date: Apr 2015
Posts: 57
Furrion 30 AM PowerSmart cord and receptacle.

Looked this up to see if there were other posts on it......there were but they were too old.

Anyway, have the PowerSmart 30 AMP Furrion cord/receptacle combo. Needless to say its not that smart after all.

Day 1 - Cord LED blue & receptacle LED blue
Day 2 - Cord LED rED & receptacle LED dead (not trying to be a poet)

Called Furrion and emailed them - they are VERY VERY hard to reach. Got Brody after 15 tries. Nice guy - sent me another cord. Said this is a problem or a large magnitude. Common issue.

New cord arrives.

Day 1 - Cord LED red - receptacle LED dead.
Day 2 - Cord LED red AND blue at same time - receptacle LED dead.

Had the campground send an electrician. Everything perfect. Clearly the PowerSmart isn't all that smart. Anyone else have a similar issue?

I do use a Progressive surge protector with the cord. Not sure if that matters.
__________________
BigPatCal is offline   Reply With Quote
Reply

Tags
power

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 08:03 AM.