Thread Tools Display Modes
Old 07-07-2014, 11:22 AM   #1
Join Date: Mar 2012
Posts: 48
Great 4th of July weekend untill....

Had a great 4th weekend with the family and a bunch of friends on our lake lot. Lots of fireworks, beverages and some swimming and fishing.

Then it was time to leave. Got everything packed and trailer cleaned and was getting the stabilizer jacks up. Have the powered Lipert (sp?) jacks. Got the back one up just fine then hit the switch on the front one and nothing . Hit the switch a few more times just to make sure was pushing it correctly... Thought OK, will just use the manual crank. Found the crank handle and tried to turn the jack. Wouldn't turn and then the little spoke things that the handle uses decided to break off. Thought a lot of words that I shouldn't really repeat here...then tried to figure out what might really be wrong.

Took switch off and thought it might be broke and it is kinda, but I was able to take the switch off the back one (broke that one in process of removing...) and put the front switch on the back jacks and they worked. Then thought well maybe I can just remove the motor and use the manual handle on that side. Well when they installed the motor ended up halfway rounding out the screws so couldn't find a hex or square driver that would work. I did check to see if power was getting to jack switch and it was.

Finally just ended up taking the jacks completely off the trailer and putting in the back of the truck so could leave.

Think this is what happened: When the jacks were installed at the factory the switch box was installed in such a way that when the little door flap that covers the switch is shut it has a habit of pressing the switch down thus causing the motor to turn on when it shouldn't. So think this happened and caused the motor to burn up and freeze. Had this happen on the back jacks not too long after we got trailer but luckily motor when out when jacks were up and not down. When the dealership fixed those (under warranty) they fixed it so the door was a little lower and wouldn't hit the switch, but they didn't do that to the front one. And I never got around to doing what they did either. So my next purchase will be some manual scissor jacks that attach to the trailer instead of the powered ones.

Sorry for the rant but just needed to get it out to some people that might understand the frustration of dealing with this along with 4 kids (our two and their friends) and a wife just trying to get packed up and go home.

Do have one question, is there anything else I should have thought of to check? I couldn't think of anything but I was getting pretty frustrated.

thanks for listening.
2012 Ford F-150 Platinum
2013 Grey Wolf 26BH
merlin66043 is offline   Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Virginia Campgrounds

Reviews provided by is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 01:03 AM.