Reply
 
Thread Tools Display Modes
Old 04-05-2016, 05:07 PM   #1
Senior Member
 
AWF1945's Avatar
 
Join Date: Dec 2012
Posts: 405
Front AC Freezing up

Im still in Alabama and have had to start using air conditioning more. The thermostat on zone 1 controls front AC. The temp setting is way off. Example, inside temp shows 83 AC set to cool 73 it never makes it without freezing up! Apparently its not cycling through defrost mode during cooling process. Any ideas or tricks? Rear unit works great.
__________________

__________________
Slim, RVing 30 plus years
2015 Dynamax DX3 37 RB
AWF1945 is offline   Reply With Quote
Old 04-05-2016, 06:19 PM   #2
GM
 
bclemens's Avatar
 
Join Date: May 2011
Location: Elkhart, IN
Posts: 7,097
Make sure the return air is not clogged in any way. Is the fan "ON or Auto"?
__________________

__________________
PLEASE do not send questions via Private Message. Post questions in the forum as a new thread so that other users can benefit from the answers. Use Private Messages for sensitive information only. Our owners manuals are available online and via iPhone/Android Apps. http://www.dynamaxcorp.com/OnlineManual.aspx
bclemens is online now   Reply With Quote
Old 04-05-2016, 07:16 PM   #3
Phat Phrog Stunt Team
 
TURBS's Avatar
 
Join Date: Aug 2011
Location: Iowa
Posts: 34,337
Frost sensor may have fallen off.



2008 2500hd Duramax
2015 Columbus 320RS
2016 nights camped "0"
2015 nights camped "34"
__________________
TURBS is offline   Reply With Quote
Old 04-05-2016, 07:36 PM   #4
Senior Member
 
R3Jones's Avatar
 
Join Date: Feb 2015
Location: Florida
Posts: 238
Along with the other suggestions, make sure there are no holes in plenum between the air exhaust and air intakes.


-R.Jones
Nitro 31FQSL
__________________
RJones
2016 Nitro 31FQSL
2017 2500 Denali Duramax
R3Jones is offline   Reply With Quote
Old 04-05-2016, 07:42 PM   #5
Phat Phrog Stunt Team
 
TURBS's Avatar
 
Join Date: Aug 2011
Location: Iowa
Posts: 34,337
Does your unit have the quick cool dump?


2008 2500hd Duramax
2015 Columbus 320RS
2016 nights camped "0"
2015 nights camped "34"
__________________
TURBS is offline   Reply With Quote
Old 04-05-2016, 09:29 PM   #6
Senior Member
 
AWF1945's Avatar
 
Join Date: Dec 2012
Posts: 405
Thanks for the replies as always.. yes air return in good shape. Unit was set on auto, yes sensor is in place, higher than one shown in picture. Mines in the center of coil located in the middle. Turbs, quick cool dump? you're talking bout defrost mode right? not sure I've heard it called that. At any rate something is not doing what its supposed to. Works great in lesser Temps.. rear unit works great no matter what the temp.
__________________
Slim, RVing 30 plus years
2015 Dynamax DX3 37 RB
AWF1945 is offline   Reply With Quote
Old 04-05-2016, 10:12 PM   #7
Phat Phrog Stunt Team
 
TURBS's Avatar
 
Join Date: Aug 2011
Location: Iowa
Posts: 34,337
Front AC Freezing up

Does your ceiling cover look like this?


2008 2500hd Duramax
2015 Columbus 320RS
2016 nights camped "0"
2015 nights camped "34"
__________________
TURBS is offline   Reply With Quote
Old 04-06-2016, 10:51 AM   #8
Senior Member
 
AWF1945's Avatar
 
Join Date: Dec 2012
Posts: 405
Turbs, what your showing looks to be from a duo therm ac unit. Mine are Coleman Mach Airxcel 4700 series
__________________
Slim, RVing 30 plus years
2015 Dynamax DX3 37 RB
AWF1945 is offline   Reply With Quote
Old 04-06-2016, 10:55 AM   #9
Phat Phrog Stunt Team
 
TURBS's Avatar
 
Join Date: Aug 2011
Location: Iowa
Posts: 34,337
Ok well I didn't know what you had and was wondering.

3 causes of freeze up

1) not enough air flow or restricted air flow. I.e. To many vents shut off or a blockage in the ducting.
2) frost sensor inoperable or fallen off.
3) unit is low on refrigerant.


2008 2500hd Duramax
2015 Columbus 320RS
2016 nights camped "0"
2015 nights camped "34"
__________________
TURBS is offline   Reply With Quote
Old 04-06-2016, 11:09 AM   #10
Senior Member
 
AWF1945's Avatar
 
Join Date: Dec 2012
Posts: 405
Thermostat reading is different than what I get from temp gun as shown. Also wall senor different from thermostat. I beginning to think I have a bad thermostat. The rear ac unit zone 2 is right on the money.
Attached Thumbnails
Click image for larger version

Name:	1459955089190.jpg
Views:	70
Size:	47.0 KB
ID:	104073   Click image for larger version

Name:	1459955109275.jpg
Views:	69
Size:	24.4 KB
ID:	104074   Click image for larger version

Name:	1459955126815.jpg
Views:	76
Size:	23.5 KB
ID:	104075  
__________________

__________________
Slim, RVing 30 plus years
2015 Dynamax DX3 37 RB
AWF1945 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 01:09 PM.