Reply
 
Thread Tools Display Modes
Old 07-13-2018, 11:41 AM   #1
Senior Member
 
Join Date: Jan 2018
Posts: 565
Help. No coach power

Just got to the coach in storage, 2019 I 5 DS. Turned batt cutoff to on. Went in coach held down Master Lights switch, all lights came on. Went in bathroom turned on Water Pump with bathroom wall switch and flushed toilet. Hit the bathroom wall vent switch to on. Reached up to push the vent power button and the coach went dark. No power to any thing. No power to the fuse panel under the bed, nor the precision Plex. No lights on any of the equipment in the Inverter equipment bay. Solar control panel is lit. Ideas? I threw all the breakers and the GFI breaker didnít reset, understandable with No Power. No lights on the fuse panel. Help?
__________________

caseymyers is offline   Reply With Quote
Old 07-13-2018, 11:54 AM   #2
Senior Member
 
FOURWHL's Avatar
 
Join Date: Mar 2016
Posts: 1,326
Plugged in or on battery? Pedestal breaker or inverter need reset?
Keep heading updtream til you find power then work back downstream to find the problem.
__________________

__________________
2016 Dynamax DX3 - Big Blue
FOURWHL is online now   Reply With Quote
Old 07-13-2018, 12:08 PM   #3
Senior Member
 
Join Date: Jan 2018
Posts: 565
Quote:
Originally Posted by FOURWHL View Post
Plugged in or on battery? Pedestal breaker or inverter need reset?
Keep heading updtream til you find power then work back downstream to find the problem.
On Batt. No shore power. Inverter bay, all equipment dead. No idiot lights on any of the equipment. So that tells me No Power down stream of the batts.
caseymyers is offline   Reply With Quote
Old 07-13-2018, 12:10 PM   #4
GM
 
bclemens's Avatar
 
Join Date: May 2011
Location: Elkhart, IN
Posts: 8,915
can you check the batteries?

Fire up the chassis? Maybe pair the two, fire up the gen?
__________________
PLEASE do not send questions via Private Message. Post questions in the forum as a new thread so that other users can benefit from the answers. Use Private Messages for sensitive information only. Our owners manuals are available online and via iPhone/Android Apps. http://www.dynamaxcorp.com/OnlineManual.aspx
bclemens is offline   Reply With Quote
Old 07-13-2018, 12:16 PM   #5
Senior Member
 
Join Date: Jan 2018
Posts: 565
Just started Generator and everything is reset and running normally. Can someone tell me what may have happened? Tripped an Automatic reset circuit breaker maybe? Or is this an anomaly of the BIRD thingy? Itís all working now but Iíd like to learn WHAT happened.

Thanks for your help.
caseymyers is offline   Reply With Quote
Old 07-13-2018, 12:19 PM   #6
GM
 
bclemens's Avatar
 
Join Date: May 2011
Location: Elkhart, IN
Posts: 8,915
The BIRD, only handles the charge lines from house to chassis or chassis to house. Would not cut out all power.
__________________
PLEASE do not send questions via Private Message. Post questions in the forum as a new thread so that other users can benefit from the answers. Use Private Messages for sensitive information only. Our owners manuals are available online and via iPhone/Android Apps. http://www.dynamaxcorp.com/OnlineManual.aspx
bclemens is offline   Reply With Quote
Old 07-13-2018, 12:21 PM   #7
Senior Member
 
Join Date: Jan 2018
Posts: 565
Batteries were normal before the event, the battery level is always the first thing my eyes see when I enter the coach. It was solar charging and reporting 13.3 volts as was the Magnum control panel when I entered the coach. I look at both. This is a resetting fuse or circuit breaker problem is my guess. Or some anomaly coming from the precision plex while it was resetting after being powered off? Or BIRD?
__________________
Old Navy Chief
2019 Isata 5 DS 4x4
2015 Jeep Rubicon Toad
caseymyers is offline   Reply With Quote
Old 07-13-2018, 12:22 PM   #8
Senior Member
 
Join Date: Jan 2018
Posts: 565
Quote:
Originally Posted by bclemens View Post
The BIRD, only handles the charge lines from house to chassis or chassis to house. Would not cut out all power.
Got it.
caseymyers is offline   Reply With Quote
Old 07-13-2018, 12:34 PM   #9
western NC mountains!
 
formerFR's Avatar
 
Join Date: Jan 2017
Location: western NC mountains!
Posts: 670
or you have a loose ground wire somewhere... you moving in the coach could have lost the connection, and the 'firing up of the generator' could also have helped 're connect' it...
__________________

The Turners
'14 Thor Palazzo 33.3 diesel
KingTailgater2 Dish, 200w/10amps mobile SOLAR
82,900 miles, US, Alaska, and Canada.. : )
formerFR is offline   Reply With Quote
Old 07-13-2018, 12:44 PM   #10
Senior Member
 
Join Date: Jan 2018
Posts: 565
New theory

I will have dealer look at it Monday. By the way still looking for a RAM warranty place, got Chrysler customer service working on it. Rv Solutions recommend Coachnet or the local Frieghtliner dealer.

New theory is that the ceiling fans are causing some anomaly in the behavior in the combination of Bath wall switch, Precision Plex fan switch and the Fan Remote. Maybe that caused the Precision Plex to trip everything off? I did not initially power the fan from Precision Plex but simply hit the wall switch in the bathroom and then touched the power switch on the fan itís self.
__________________

caseymyers is offline   Reply With Quote
Reply

Tags
power

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Featured Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 08:03 PM.