Reply
 
Thread Tools Display Modes
Old 10-21-2017, 01:23 PM   #1
Junior Member
 
Join Date: Jul 2017
Posts: 2
iSata 5 stairs stopped extending

After a camping trip with some electrical issues, inverter had some faults probably due to being connected to 30 amp service my stairs stopped extending. They stairs were extending and retracting fine upon leaving the rv park but upon returing to final destination a few hours later they would not extend. Electrical is all fine now after rebooting the inverter but still not extension, any suggestions?
__________________

Jbluto is offline   Reply With Quote
Old 10-21-2017, 01:57 PM   #2
Senior Member
 
Join Date: Mar 2017
Location: Ann Arbor, MI
Posts: 148
Quote:
Originally Posted by Jbluto View Post
After a camping trip with some electrical issues, inverter had some faults probably due to being connected to 30 amp service my stairs stopped extending. They stairs were extending and retracting fine upon leaving the rv park but upon returing to final destination a few hours later they would not extend. Electrical is all fine now after rebooting the inverter but still not extension, any suggestions?
I've had that happen once on my Isata 5. Look under the steps and tap on the controller box. Mine started to work after that and have continued ok.
__________________

__________________
2017 Isata 5 DB
Teich is offline   Reply With Quote
Old 10-21-2017, 03:06 PM   #3
Senior Member
 
Join Date: Nov 2016
Posts: 353
Did you check for a bad fuse in the controller under the bed?
__________________
Pat
2017 Isata 5
Whalenss is offline   Reply With Quote
Old 10-22-2017, 07:51 AM   #4
Senior Member
 
DavidMort's Avatar
 
Join Date: May 2016
Posts: 219
Similar problem: just posted last update to this thread:
entry steps not working
__________________
2017 Isata 5 DS
DavidMort is offline   Reply With Quote
Old 10-22-2017, 03:24 PM   #5
Junior Member
 
Join Date: Jul 2017
Posts: 2
Thanks for the responses and suggestions, I checked the inline fuse and it is intact. I noticed this purple wire with a connector on one side which appears to be disconnected to another side. Anyone have this wire connected? it seems part of the connector may have come off severing a connection.
Jbluto is offline   Reply With Quote
Old 10-22-2017, 04:30 PM   #6
Senior Member
 
Join Date: Nov 2016
Posts: 353
Quote:
Originally Posted by Jbluto View Post
Thanks for the responses and suggestions, I checked the inline fuse and it is intact. I noticed this purple wire with a connector on one side which appears to be disconnected to another side. Anyone have this wire connected? it seems part of the connector may have come off severing a connection.


No, purple and a white wire with connectors but not connected to anything.
__________________

__________________
Pat
2017 Isata 5
Whalenss is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Featured Campgrounds

Reviews provided by


Disclaimer:

This website is not affiliated with or endorsed by Forest River, Inc. or any of its affiliates. This is an independent, unofficial site.




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 11:55 PM.