Reply
 
Thread Tools Display Modes
Old 10-18-2019, 05:50 PM   #1
Señor Miembro
 
Rancher Rob's Avatar
 
Join Date: Dec 2018
Location: SW Washington state
Posts: 170
Kenwood radio Initial Setup Finish never goes away?

Everytime I start up the coach, I get this message on the radio (new Kenwood DNX775RV). I've gone through the setup so why does this always come back? It happened with the previous kenwood too. Could it be something with the wiring? Any ideas?
Attached Thumbnails
Click image for larger version

Name:	radio setup.jpg
Views:	59
Size:	337.4 KB
ID:	217572  
__________________

Rancher Rob is offline   Reply With Quote
Old 10-18-2019, 06:15 PM   #2
Senior Member
 
Join Date: Jun 2017
Location: Running Springs, CA
Posts: 807
Did you push the 'finish' button?
__________________

__________________
2018 DX3 37TS Sunset
2019 Rubicon JLU
2018 RZR XP 1000 Ride Command
rskeans is offline   Reply With Quote
Old 10-18-2019, 06:20 PM   #3
Junior Member
 
Join Date: Sep 2019
Posts: 8
This is probably a wiring issue. There are two wires on the radio that require 12v+. One should have 12v+supplied constantly. The other one should have 12v+ supplied once the key is turned on. I would bet that both of those wires are tied together and connected to a switched source. Looking from the back of the radio they are most likely the red and yellow wires.
ricerocketroaster is offline   Reply With Quote
Old 10-18-2019, 06:22 PM   #4
Junior Member
 
Join Date: Sep 2019
Posts: 8
Quote:
Originally Posted by rskeans View Post
Did you push the 'finish' button?
Great eye!!!
ricerocketroaster is offline   Reply With Quote
Old 10-18-2019, 06:24 PM   #5
Señor Miembro
 
Rancher Rob's Avatar
 
Join Date: Dec 2018
Location: SW Washington state
Posts: 170
Quote:
Originally Posted by rskeans View Post
Did you push the 'finish' button?
I hadn't thought of that!
Yes, I press 'Finish' every time to make the screen go away.

I'll check that wiring possibility, thanks.
Rancher Rob is offline   Reply With Quote
Old 10-18-2019, 07:36 PM   #6
Senior Member
 
Join Date: Nov 2017
Location: Barboursville, wv
Posts: 286
Quote:
Originally Posted by Rancher Rob View Post
Everytime I start up the coach, I get this message on the radio (new Kenwood DNX775RV). I've gone through the setup so why does this always come back? It happened with the previous kenwood too. Could it be something with the wiring? Any ideas?
I get it too. I believe it’s down to the fact of turning off the battery isolation switch.
__________________
Bob, MacKenzie & the boys.
2018 Dynamax DX3BH, 2019 Lincoln Navigator L.
Motorhome1 is offline   Reply With Quote
Old 10-19-2019, 09:49 AM   #7
Senior Member
 
Join Date: Jun 2017
Location: Running Springs, CA
Posts: 807
Is this replacement Kenwood just an plug for plug swap for the OEM radio?
__________________
2018 DX3 37TS Sunset
2019 Rubicon JLU
2018 RZR XP 1000 Ride Command
rskeans is offline   Reply With Quote
Old 10-19-2019, 10:52 AM   #8
Senior Member
 
halla's Avatar
 
Join Date: Mar 2015
Location: Akron, OH
Posts: 2,513
My red and yellow wires were reversed. When you shut off the truck it loses its memory. Check the red and yellow to see which is constant power when the key is off, that should be wired to the yellow on the radio.
__________________
2018 Dynamax Force HD BH---Just Rite-2
halla is offline   Reply With Quote
Old 10-19-2019, 11:07 AM   #9
Jim & Gerry
 
Join Date: Aug 2015
Location: Louisiana
Posts: 49
Us too-

Thought it was me not knowing how to operate the radio.

Exactly what do I do to fix this? Would be nice to be able to run the radio while in the campground! And it is very aggravating to do the setup routine every time the engine is turned on!

Please start with how do I get to the back of the radio—- hubby will understand more than me!

Thanks
__________________
Jim & Gerry
Louisiana
Dynamax DX3 37 TS
Jeep Renegade
MovnOn is offline   Reply With Quote
Old 10-19-2019, 08:39 PM   #10
Senior Member
 
halla's Avatar
 
Join Date: Mar 2015
Location: Akron, OH
Posts: 2,513
Pull the dash, 2 screws holding the radio in place, will slide right out. The dash comes off with some screws, pretty easy to remove.
__________________
2018 Dynamax Force HD BH---Just Rite-2
halla is offline   Reply With Quote
Old 11-16-2019, 04:37 PM   #11
Jim & Gerry
 
Join Date: Aug 2015
Location: Louisiana
Posts: 49
More info please

Hubby took out a ton of screws, dash came off. He said it looks like the radio is in a can. There were 4 screws holding the can in place. Does the can come out or the radio come out of the can?

Could not get the radio out
__________________
Jim & Gerry
Louisiana
Dynamax DX3 37 TS
Jeep Renegade
MovnOn is offline   Reply With Quote
Old 11-16-2019, 04:39 PM   #12
Senior Member
 
halla's Avatar
 
Join Date: Mar 2015
Location: Akron, OH
Posts: 2,513
On ours there are two screws at the top of the radio and then it slides out as a whole. It is heavy with a lot of wires so sometimes I reach behind and push a little. Take the top of the dash of to help.
halla is offline   Reply With Quote
Old 11-16-2019, 05:21 PM   #13
Jim & Gerry
 
Join Date: Aug 2015
Location: Louisiana
Posts: 49
Thanks

Will try again next weekend
__________________
Jim & Gerry
Louisiana
Dynamax DX3 37 TS
Jeep Renegade
MovnOn is offline   Reply With Quote
Old 11-19-2019, 02:28 PM   #14
Junior Member
 
Join Date: Nov 2019
Posts: 16
Halla I just pulled my radio out also. The red and yellow wires are hooked up in reverse of the Kenwood manual. A dynamax person just called me back and said he would talk to his engineers about it. There are four screws holding the radio.
ci4mynewf is offline   Reply With Quote
Old 11-20-2019, 11:55 AM   #15
Jim & Gerry
 
Join Date: Aug 2015
Location: Louisiana
Posts: 49
No luck yet!

Got a chance to try again; removed the dash, removed the four screws, but can’t get the radio out.

It is in a can. Does the whole can come out with the radio, or do we have to get the radio out of the can? I don’t want to force anything. It just doesn’t want to come out either way! Are there any tabs or?

Not sure what to do next— thanks, Jim
Attached Thumbnails
Click image for larger version

Name:	8708D9D8-D511-4382-B63C-127F2062C16E.jpg
Views:	45
Size:	395.1 KB
ID:	219498  
__________________
Jim & Gerry
Louisiana
Dynamax DX3 37 TS
Jeep Renegade
MovnOn is offline   Reply With Quote
Old 11-20-2019, 03:07 PM   #16
Senior Member
 
Join Date: Nov 2017
Location: Barboursville, wv
Posts: 286
Just grab the can ( where the screws go) and it should just pull out. Looks like it’s already moved a little
__________________
Bob, MacKenzie & the boys.
2018 Dynamax DX3BH, 2019 Lincoln Navigator L.
Motorhome1 is offline   Reply With Quote
Old 11-20-2019, 09:06 PM   #17
Jim & Gerry
 
Join Date: Aug 2015
Location: Louisiana
Posts: 49
Don’t want to break it

I put a great deal of force on it. It came out about two inches. It feels like something is holding it on the top.
__________________
Jim & Gerry
Louisiana
Dynamax DX3 37 TS
Jeep Renegade
MovnOn is offline   Reply With Quote
Old 11-20-2019, 09:08 PM   #18
Senior Member
 
halla's Avatar
 
Join Date: Mar 2015
Location: Akron, OH
Posts: 2,513
Did you take the dash top off so you can see what is holding it? There arent that many screws that hold the top on. The wiring may be tied up holding it in place.
__________________
2018 Dynamax Force HD BH---Just Rite-2
halla is offline   Reply With Quote
Old 11-21-2019, 11:16 PM   #19
GB1
Junior Member
 
Join Date: Apr 2019
Location: Guffey, CO
Posts: 14
Yellow memory wire not properly attached

We took delivery of our 2020 Dynaquest XL 3801ts 2 weeks ago and spent 10 days in it. We have the same problem with the setup screen and Sirius always starts with the Preview even though we have a subscription. I called Kenwood. I was told the yellow memory wire is not properly attached. On top of that, our radio is installed in a very crooked manner and it cannot open to insert a CD.

Just one of many irritating issues we’ve found. Overall we like the coach but disappointed in the lack of attention to detail considering the price and the 3+ month build. A bit of a let down after 6 months of anticipation.

We spent a couple nights in single digits and we’re impressed that the Aqua Hot and fireplace worked well enough to keep anything from freezing. We were hooked to 30 amp electricity and had a small heater available when necessary.

Now to take the dash apart to get the radio to work properly or deal with warranty repair...
GB1 is offline   Reply With Quote
Old 11-22-2019, 06:10 AM   #20
Junior Member
 
Join Date: Nov 2019
Posts: 16
GB1 I agree with you about the little things that are wrong about the rig. I ordered a DX3 TS six months ago and they built mine with a loveseat. I ordered a fireplace. Didn't want to wait another six months so a took it the way it was.
Your right about the yellow wire. I just attached my yellow to the red wire with a blue piercing clip. You just have to power down the radio with the menu button on the radio.
__________________

ci4mynewf is offline   Reply With Quote
Reply

Tags
radio

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Forest River, Inc. or any of its affiliates. This is an independent, unofficial site.



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 02:05 AM.


×