Reply
 
Thread Tools Display Modes
Old 12-08-2019, 05:21 PM   #1
Member
 
viperdave's Avatar
 
Join Date: Jun 2016
Posts: 79
Lost 12V inside DX3

I returned from quick trip to the sand dunes with all going well. Plugged my rig in the following day to shore power and discovered that no 12V is working inside the coach. Batteries are charging, I have 110v inside the coach. Xantrex is working, front slide works but nothing else operates. The rear slide will not move, coach and generator starts.

The 12v fuses below by the inverter are ok and I seem to have 12v running through the relays down there. I found one spot where 12v wasn't flowing through but don't have a picture. It looked like a relay with an additional circuit board and a fuse on it, unlike the other normal looking relays.

Any ideas???

Thanks!
__________________

__________________
2016 Dynamax DX3
viperdave is offline   Reply With Quote
Old 12-08-2019, 05:47 PM   #2
Senior Member
 
Jpheifer's Avatar
 
Join Date: Jul 2019
Location: Bettendorf Iowa
Posts: 187
Quote:
Originally Posted by viperdave View Post
I returned from quick trip to the sand dunes with all going well. Plugged my rig in the following day to shore power and discovered that no 12V is working inside the coach. Batteries are charging, I have 110v inside the coach. Xantrex is working, front slide works but nothing else operates. The rear slide will not move, coach and generator starts.



The 12v fuses below by the inverter are ok and I seem to have 12v running through the relays down there. I found one spot where 12v wasn't flowing through but don't have a picture. It looked like a relay with an additional circuit board and a fuse on it, unlike the other normal looking relays.



Any ideas???



Thanks!


Did you check your 12v fuses ate the power center where the 120 breakers are?
__________________

__________________
Joe Pheifer
DX3
Jpheifer is offline   Reply With Quote
Old 12-08-2019, 05:49 PM   #3
Member
 
viperdave's Avatar
 
Join Date: Jun 2016
Posts: 79
yes, pulled them and verified with voltmeter that no 12v is active at the fuse panel inside by the 120 breakers.
__________________
2016 Dynamax DX3
viperdave is offline   Reply With Quote
Old 12-08-2019, 05:50 PM   #4
Senior Member
 
Jpheifer's Avatar
 
Join Date: Jul 2019
Location: Bettendorf Iowa
Posts: 187
Quote:
Originally Posted by viperdave View Post
yes, pulled them and verified with voltmeter that no 12v is active at the fuse panel inside by the 120 breakers.


I think in the bay by the inverter there is a master 12 v breaker that takes 12v back to that panel - check it there is more than one in there
__________________
Joe Pheifer
DX3
Jpheifer is offline   Reply With Quote
Old 12-08-2019, 09:36 PM   #5
Senior Member
 
Join Date: Jul 2016
Posts: 1,320
have you checked this relay? feed Your 12V panel, mine is under the King bed
Attached Thumbnails
Click image for larger version

Name:	relay.jpg
Views:	48
Size:	223.4 KB
ID:	220302  
__________________
Joe & Kathy
2017 Dynamax DX3 37BH
Toad: 2019 Ford Explorer
2018: days camped 126
2019: days camped 97
2020: days camped 0
joet19711 is offline   Reply With Quote
Old 12-08-2019, 09:40 PM   #6
Senior Member
 
Join Date: Jul 2016
Posts: 1,320
also this, it would be the relay in the upper right corner
Attached Thumbnails
Click image for larger version

Name:	elec comp fuses and relays.jpg
Views:	50
Size:	237.1 KB
ID:	220303  
__________________
Joe & Kathy
2017 Dynamax DX3 37BH
Toad: 2019 Ford Explorer
2018: days camped 126
2019: days camped 97
2020: days camped 0
joet19711 is offline   Reply With Quote
Old 12-08-2019, 09:49 PM   #7
Member
 
viperdave's Avatar
 
Join Date: Jun 2016
Posts: 79
that is the one Joe! Mine is down below by the inverter. It was the only place down below that I couldn't get 12v with the voltmeter. The fuse looked ok but now that I think about it, I didn't verify 12 volt at that fuse either.


So am I to think that the relay is bad then? What is the name of that relay or how to I find out what/where to order?


Thanks for your help and great photo!
__________________
2016 Dynamax DX3
viperdave is offline   Reply With Quote
Old 12-08-2019, 11:49 PM   #8
Senior Member
 
AWF1945's Avatar
 
Join Date: Dec 2012
Location: Tennessee
Posts: 757
Not trying to redirect by no means... but what a huge difference in wiring from 2015 to 2016.. looks like a complete change. I will be following this post.
__________________
Slim, RVing 30 plus years
2015 Dynamax DX3 37 RB
AWF1945 is offline   Reply With Quote
Old 12-09-2019, 06:55 AM   #9
Senior Member
 
Jpheifer's Avatar
 
Join Date: Jul 2019
Location: Bettendorf Iowa
Posts: 187
Quote:
Originally Posted by AWF1945 View Post
Not trying to redirect by no means... but what a huge difference in wiring from 2015 to 2016.. looks like a complete change. I will be following this post.


I was trying to help - but mine is. 2015 as well and it looks very different as you said
__________________
Joe Pheifer
DX3
Jpheifer is offline   Reply With Quote
Old 12-09-2019, 07:04 AM   #10
Senior Member
 
Join Date: Jul 2016
Posts: 1,320
Quote:
Originally Posted by viperdave View Post
that is the one Joe! Mine is down below by the inverter. It was the only place down below that I couldn't get 12v with the voltmeter. The fuse looked ok but now that I think about it, I didn't verify 12 volt at that fuse either.


So am I to think that the relay is bad then? What is the name of that relay or how to I find out what/where to order?


Thanks for your help and great photo!
Pretty sure this is the one
https://www.amazon.com/KIB-LR9806-La.../dp/B009WQPL2U

If you want to make sure, take jumper from one side to the other on the relay. It supplies 12V to the panel.
My relay went out while we were out on the road. I took a battery jumper cable and clamped from one side to the other. I was able to make it home
and then got a new one. Pretty easy fix.
__________________
Joe & Kathy
2017 Dynamax DX3 37BH
Toad: 2019 Ford Explorer
2018: days camped 126
2019: days camped 97
2020: days camped 0
joet19711 is offline   Reply With Quote
Old 12-09-2019, 09:29 AM   #11
Senior Member
 
Join Date: Jul 2016
Posts: 1,320
Quote:
Originally Posted by joet19711 View Post
also this, it would be the relay in the upper right corner
Yes, this is in the electronics bay. My 12v panel is by the king bed.

just to verify.
__________________
Joe & Kathy
2017 Dynamax DX3 37BH
Toad: 2019 Ford Explorer
2018: days camped 126
2019: days camped 97
2020: days camped 0
joet19711 is offline   Reply With Quote
Old 12-09-2019, 10:09 AM   #12
Member
 
viperdave's Avatar
 
Join Date: Jun 2016
Posts: 79
That certainly looks like it. I will definitely try and jumper it. Sometimes the obvious quick check is difficult to see! I will jumper and do a check then order the "latching relay". So nice to have a name to go with a part.


Thanks Joe for sharing your experience.
__________________
2016 Dynamax DX3
viperdave is offline   Reply With Quote
Old 12-09-2019, 10:20 AM   #13
Senior Member
 
Join Date: Jul 2016
Posts: 1,320
Quote:
Originally Posted by viperdave View Post
That certainly looks like it. I will definitely try and jumper it. Sometimes the obvious quick check is difficult to see! I will jumper and do a check then order the "latching relay". So nice to have a name to go with a part.


Thanks Joe for sharing your experience.
That's why this forum is so great! Glad that I could help

Joe
__________________
Joe & Kathy
2017 Dynamax DX3 37BH
Toad: 2019 Ford Explorer
2018: days camped 126
2019: days camped 97
2020: days camped 0
joet19711 is offline   Reply With Quote
Old 12-09-2019, 10:41 AM   #14
Dynamax Service Rep
 
Join Date: Nov 2019
Posts: 15
I agree with the above replies,probably the latching solonoid,have someone push the aux start button on the dash and see if it supplies power to the other side of said solonoid
GTinsman is offline   Reply With Quote
Old 12-16-2019, 01:00 PM   #15
Member
 
viperdave's Avatar
 
Join Date: Jun 2016
Posts: 79
Got the new relay installed this morning and BAM, 12v power inside coach is restored. Thanks everyone!!!!
__________________
2016 Dynamax DX3
viperdave is offline   Reply With Quote
Old 12-16-2019, 06:23 PM   #16
Senior Member
 
Join Date: Apr 2017
Posts: 656
Good deal!

Thanks for updating this thread and closing the loop for all of us following along.
__________________

__________________
2018 DX3 37BH
mookieblaylock is online now   Reply With Quote
Reply

Tags
dx3

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Forest River, Inc. or any of its affiliates. This is an independent, unofficial site.



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 04:27 PM.


×