Reply
 
Thread Tools Display Modes
Old 02-07-2018, 06:23 AM   #1
Member
 
Join Date: Nov 2014
Posts: 50
2015 MB 24 -- No Running Lights - Hopkins Controller

I am on my 3rd or 4th controller ... and my 2nd relay (also mounted on the aluminum post in the back) .. The last time .. the 'repair' lasted 2 weeks. I .. again ... do not have running lights and several of the LEDs in the right tail light are not fully lit. Has anyone had a successful repair with this situation? I know it must be moisture somewhere back there and vibration ... I think its a combination of the electronics on that aluminum post ( controller, 2 resisters and a relay) .. and now I suspect that has burnt out some LEDs cause when it was working I still had a few LEDs not working .. but now when the running lights are not working I have about 1/2 of them not working. Its been sitting at the dealer for 3 weeks now waiting on another controller from FR ... but I believe that the controller issue has not created other failures further down stream in the electrical system. Any suggestions? 2015 MB 24RS .... I have been dealing with this for over a year now and it is driving me crazy ... plus I can't use my MB RV which I really love. I am losing faith ..
__________________

oregonct is offline   Reply With Quote
Old 02-07-2018, 07:11 AM   #2
Senior Member
 
Rich.M's Avatar
 
Join Date: Jan 2016
Location: Sarasota
Posts: 510
Are you using the original Curt controller or the new recall replacement? One ares to look for moisture or a short is the 7 pin trailer plug , the lighting output goes there as well and moisture and corrosion at the wire to plug connections have potential to cause a short
__________________

__________________
2015 Solera 24r
2017 Jeep Wrangler
Rich.M is offline   Reply With Quote
Old 02-07-2018, 07:15 AM   #3
Member
 
Join Date: Nov 2014
Posts: 50
Thanks .. I am using the replacement (2nd .. now 3rd one). I will check the 7 pin as well for a short. The last time I replaced the controller .. the lights did not go on until I replaced the relay ... then after 2 weeks I was back in the same situation ... I replaced the relay again .. still no lights.
oregonct is offline   Reply With Quote
Old 02-11-2018, 12:05 AM   #4
Senior Member
 
Join Date: Sep 2016
Posts: 231
We had to replace the Curt controller last summer after driving through a downpour while 2500 miles from home. Called FR and they sent us a Hopkins unit. So far so good. We had a rv repair place put the new one in. We've been thinking of using a rectangular plastic box to cover it just to make sure it stays dry. It's placement on the vehicle is stupid imo.
Desertsquid is offline   Reply With Quote
Old 02-11-2018, 12:09 AM   #5
Senior Member
 
Join Date: Sep 2016
Posts: 231
There's no reason for a 3 week wait for the part. That's just wrong.
Desertsquid is offline   Reply With Quote
Old 02-11-2018, 08:29 AM   #6
Member
 
Join Date: Nov 2014
Posts: 50
Curt Controller Replacement.

Yes, the 3rd and now 4th controller are the new ones. The part came in this week and it was replaced by the Tech. It rained yesterday ... The right turn signal is flashing fast .. all bulbs are functioning ... its intermittent. The lights turn on every time so far but in one instance ... it took 3 seconds before the back lights went on. I do not believe I am done with this repair yet:-( ... I'm asking FR if they will authorize the replacement of the resistor and relay that are also mounted on that post on the back. I did ask if they would authorize it being mounted inside the 'basement' ... They said no need. I have not heard back yet on the resistor and relay request. I did also replace the right turn signal as the initial blow out of the controller blew out some of the LEDs ... so far they are all still working. The dealer said they have another customer with similar issues. The controller delayed turning not he lights for 30 minutes in freezing temperatures.
oregonct is offline   Reply With Quote
Old 02-16-2018, 06:18 PM   #7
Senior Member
 
namusmc's Avatar
 
Join Date: Sep 2014
Location: Grass Valley, CA
Posts: 337
Quote:
Originally Posted by oregonct View Post
I am on my 3rd or 4th controller ... and my 2nd relay (also mounted on the aluminum post in the back) .. The last time .. the 'repair' lasted 2 weeks. I .. again ... do not have running lights and several of the LEDs in the right tail light are not fully lit. Has anyone had a successful repair with this situation? I know it must be moisture somewhere back there and vibration ... I think its a combination of the electronics on that aluminum post ( controller, 2 resisters and a relay) .. and now I suspect that has burnt out some LEDs cause when it was working I still had a few LEDs not working .. but now when the running lights are not working I have about 1/2 of them not working. Its been sitting at the dealer for 3 weeks now waiting on another controller from FR ... but I believe that the controller issue has not created other failures further down stream in the electrical system. Any suggestions? 2015 MB 24RS .... I have been dealing with this for over a year now and it is driving me crazy ... plus I can't use my MB RV which I really love. I am losing faith ..
Noticed my right rear tail light stayed very dimly lit even though all light switches were off. It stayed dimly lit even with coach and chassis power disconnected.

At first I thought I had discovered a new source of electricity. Had my Curt controller replaced with a Hopkins controller last year under the factory recall. Never had any lighting problems before. Dealer could not look at the problem right away because their service dept. was fully booked.

So, I got under the 2016 2401W and checked all the controller connections to see if I could find a bad connection. All seemed to look OK. Lifted the cover flap for the 7 point trailer connector and it had all this light bluish/green damp gelatinous goo inside that looked like corrosion stuff.

Cleaned the goo out of the connector with Q tips and wiped everything clean. Checked the tail light again and it was off! Problem fixed.

This might be something other posters may want to check. At least it worked for me.
namusmc is offline   Reply With Quote
Old 02-17-2018, 08:10 AM   #8
Member
 
Join Date: Nov 2014
Posts: 50
FR has been very helpful .. It is taking too much time to resolve but it is a difficult issue. They replaced the controller again .. and now I have a fast blinker on the right tail light (also replaced) ... They are ordering me new taillights (new version) and I have also noticed the wiring near the relay seems to be chaffed .. so I am hoping that once the new lights are in (special order) and the dealer rewires the relay and does a complete inspection of the wiring in that area that we can put this issue behind us. FR also inspected the 7 pin and did not find that to be impacting this issue .. but it was the first thing they wanted to inspect.
__________________

oregonct is offline   Reply With Quote
Reply

Tags
controller, light

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Forest River, Inc. or any of its affiliates. This is an independent, unofficial site.



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 09:20 PM.


×