Thread Tools Display Modes
Old 10-03-2016, 10:18 AM   #41
Senior Member
Join Date: Jun 2012
Posts: 3,747
Dirty contacts creating a large resistance (i.e. voltage drop)?

Try removing the battery connections and cleaning them. Long shot, but worth a try.

1988 Coleman Sequoia - popup (1987-2007)
2012 Roo19 - hybid (2012-2015)

2016 Mini Lite 2503S - tt (2015 - ???)
2011 Traverse LT, 3.6L, FWD
2009 Silverado Ext Cab, 5.3L, 4x4, 3.73
2016 Silverado 2500HD Dbl Cab, 6.0L 4x4, 4.10
rockfordroo is offline   Reply With Quote
Old 10-03-2016, 10:22 AM   #42
Senior Member
Join Date: Nov 2015
Location: Madison, Wisconsin
Posts: 143
If the hydrometer readings are accurate then the batteries should be good. Could be a converter / charger issue. If it wasn't providing a float charge that might be a possible cause.

2015 Solaire 201SS
2015 GMC 2500HD Duramax
PSU Turf is offline   Reply With Quote

electric, electrical

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Virginia Campgrounds

Reviews provided by is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 04:08 AM.