Thread Tools Display Modes
Old 01-06-2016, 08:11 PM   #1
Senior Member
Join Date: Sep 2015
Location: Georgetown Kentucky
Posts: 171
Generator only works for 15min max

I have a QG 3600 Cummins Onan LP Generator on our 2016 Sunseeker MBS. Upon delivery I understood how to prime and start, and I tried it a couple of other times but then shut it off. We just went on our first trip where we could of used it and I learned it will not run for more than 15 min without shutting off.

After a lot of research on the web, I learned I have a code 35 based on the blinking sequence. I called the Cummins Onan service center today and they looked it up and said I needed a software update and would need to bring it in.

I wanted to post this to at least let everyone know. Your supposed to spend a few hours breaking it in when new and best to do that process while your home, starting is great but you want to make sure it runs longer than 15 min.

Fyi - I have 1.4 hours on the generator.

2016 Sunseeker W MBS
kysunseekermbs is offline   Reply With Quote
Old 01-07-2016, 09:23 AM   #2
Senior Member
Join Date: Feb 2015
Posts: 116
There is a Cummins service center near me in Michigan. I wonder if that's who you spoke to. I called them when I had some questions about my diesel generator. I was glad to know that if I had problems they are 30 mins from my work!


2016 Sunseeker MBS 2400R + Diesel Gen
2014 Honda CRV
Blue Ox Flat Tow Equipment
SMI Stay-In-Play Brake Controller
ericlakin is offline   Reply With Quote
Old 01-07-2016, 01:34 PM   #3
Join Date: Sep 2014
Location: Grass Valley, CA
Posts: 90
Make sure the genset crankcase isn't over filled, not even slightly.
namusmc is online now   Reply With Quote
Old 01-19-2016, 11:44 AM   #4
Senior Member
Join Date: Sep 2015
Location: Georgetown Kentucky
Posts: 171
Here is some valuable info / update. Just finished a half day of driving and waiting at my nearest cummins onan dealer for my generator problem to be diagnosed.

The problem with the generator cutting out after running anywhere from 1-10 minutes was due to a vent hose that comes out of the bottom of the generator. It looks like a sponge filter on the bottom of the hose and it was clogged with dust. It is directly behind the rear wheel so this is something I will have to pay attention to in the future. He said the sponge filter on the hose is to keep out mud daubers but it is not needed other than that.

Hope this info helps someone in the future with a generator that keeps dying but starts perfectly.
2016 Sunseeker W MBS
kysunseekermbs is offline   Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Virginia Campgrounds

Reviews provided by is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 11:31 AM.