Reply
 
Thread Tools Display Modes
Old 07-19-2015, 07:51 PM   #11
Senior Member
 
wifeytojosh's Avatar
 
Join Date: Jun 2013
Posts: 102
It was reading 12.8 connected to shore power and unplugged from shore power
__________________

__________________
wifeytojosh is offline   Reply With Quote
Old 07-19-2015, 07:53 PM   #12
Site Team - Lou
 
Herk7769's Avatar
 
Join Date: Oct 2009
Location: South Eastern PA
Posts: 21,169
You may have blown the current limiter that protects the battery when you unhooked the old one or connected the new one.

Look for one of these; they have a reset button on the side.
Some have a red rubber cap for protection.
Attached Thumbnails
Click image for larger version

Name:	30407-20.jpg
Views:	55
Size:	32.2 KB
ID:	83392   Click image for larger version

Name:	360426586.jpg
Views:	52
Size:	57.9 KB
ID:	83393  
Attached Images
 
__________________

__________________

Lou and Laura with Bella - German Short Hair Pointer
2008 GMC Sierra 2500HD Crewcab SB Allison Duramax
2010 Flagstaff 8526RLWS - Superglide 3300
HAM CALLSIGN - KC3FFW
Herk7769 is offline   Reply With Quote
Old 07-19-2015, 07:54 PM   #13
Site Team - Lou
 
Herk7769's Avatar
 
Join Date: Oct 2009
Location: South Eastern PA
Posts: 21,169
Also check your ground; it could be why your old battery was not charging as well.
Attached Thumbnails
Click image for larger version

Name:	Horst Probe Install 017.jpg
Views:	44
Size:	431.9 KB
ID:	83397  
__________________

Lou and Laura with Bella - German Short Hair Pointer
2008 GMC Sierra 2500HD Crewcab SB Allison Duramax
2010 Flagstaff 8526RLWS - Superglide 3300
HAM CALLSIGN - KC3FFW
Herk7769 is offline   Reply With Quote
Old 07-19-2015, 07:58 PM   #14
Senior Member
 
wifeytojosh's Avatar
 
Join Date: Jun 2013
Posts: 102
Is the reset button on the battery?
__________________
wifeytojosh is offline   Reply With Quote
Old 07-19-2015, 07:58 PM   #15
clr
Senior Member
 
Join Date: Jul 2014
Location: Sherman Illinois
Posts: 661
Well if it is reading 12.8 volts the battery is fully charged and therefore not the problem. Make sure that the battery is not connected backwards in the RV, positive from the battery should be going to the coach main converter fuse panel. The negative lead from the battery is connected to the frame of the unit and you can normally see where it is connected to the frame close to the battery. Also make sure that if you have a battery disconnect that it is not operated cutting off the battery from the coach.
__________________
clr is offline   Reply With Quote
Old 07-19-2015, 08:00 PM   #16
Senior Member
 
wifeytojosh's Avatar
 
Join Date: Jun 2013
Posts: 102
The ground is good. We have checked.
__________________
wifeytojosh is offline   Reply With Quote
Old 07-19-2015, 08:01 PM   #17
clr
Senior Member
 
Join Date: Jul 2014
Location: Sherman Illinois
Posts: 661
Follow the positive lead from the battery and you should find the fuse you are looking for and the reset button. On a travel trailer many times the fuse is on the underside of the frame going to the coach.
__________________
clr is offline   Reply With Quote
Old 07-19-2015, 08:02 PM   #18
Site Team - Lou
 
Herk7769's Avatar
 
Join Date: Oct 2009
Location: South Eastern PA
Posts: 21,169
Quote:
Originally Posted by wifeytojosh View Post
Is the reset button on the battery?
No its on the side of the current limiter (the little button on the side).

The current limiter may be under the frame near the metal box your umbilical cord goes into.
Attached Thumbnails
Click image for larger version

Name:	DSCF5737.jpg
Views:	45
Size:	180.7 KB
ID:	83398   Click image for larger version

Name:	DSCF5739.jpg
Views:	42
Size:	201.2 KB
ID:	83399   Click image for larger version

Name:	360426586.jpg
Views:	44
Size:	57.9 KB
ID:	83400  
__________________

Lou and Laura with Bella - German Short Hair Pointer
2008 GMC Sierra 2500HD Crewcab SB Allison Duramax
2010 Flagstaff 8526RLWS - Superglide 3300
HAM CALLSIGN - KC3FFW
Herk7769 is offline   Reply With Quote
Old 07-19-2015, 08:04 PM   #19
Senior Member
 
wifeytojosh's Avatar
 
Join Date: Jun 2013
Posts: 102
Ok, let me go check
__________________
wifeytojosh is offline   Reply With Quote
Old 07-19-2015, 08:09 PM   #20
Senior Member
 
wifeytojosh's Avatar
 
Join Date: Jun 2013
Posts: 102
Have white(negative) going into the frame and red(positive) going into the rigClick image for larger version

Name:	ImageUploadedByForest River Forums1437350970.562908.jpg
Views:	60
Size:	68.8 KB
ID:	83406
__________________

__________________
wifeytojosh is offline   Reply With Quote
Reply

Tags
battery

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 09:06 AM.