Reply
 
Thread Tools Display Modes
Old 04-24-2015, 08:41 AM   #1
Junior Member
 
Join Date: Apr 2015
Posts: 1
black tank flush

I have an Hemisphere 368 RLBH (2015) new... I connected the water hose to the black tank flush system and notice that no water was going in... and the flushing system was not working properly. I took it to the dealer and they claim that this is normal... they change the check valve and still I feel nothing is going in.... they also claim that is low pressure system and that's why a little water is coming out.... for me that sound BS.

any help out there for my issue...
__________________

__________________
salsa2me is offline   Reply With Quote
Old 04-24-2015, 08:55 AM   #2
Senior Member
 
Join Date: Feb 2012
Posts: 1,101
That sounds like BS to me to. I don't have an enclosed belly so when I turn mine on I can hear the water hitting the sides of the tank. The amount of water coming out is almost the same a 3/4 open hose.
__________________

__________________
Ontario

Vibe 6501
1 Prospector Canoe
2 Mtn. Bikes
4 Hiking Boots
Happy Vibe is offline   Reply With Quote
Old 04-24-2015, 09:06 AM   #3
Senior Member
 
RSchleder's Avatar
 
Join Date: Apr 2014
Location: Iowa
Posts: 1,277
I do have an enclosed belly and I can still hear the water spraying (strong spray too) as I clean the black tank. I have had several RV's, including 2 DP'ers that I also clearly heard the black water spray.
The water coming from the tank during the spraying process will not look like a lot as it's going into the tank in a 5/8 or 3/4" hose and exiting in a 4" dump hose so take this into consideration.
Do you have a clear elbow on your drain hose. If so, the water should slowly clear up during the "spraying process" in a few minutes. This is another check to see if your spraying system is functioning!
__________________
Days camping (2016)----181 days
Days camping (2017) --- 82 days
2016 Wildcat MAXX 28RKX (33' TT), 2007 13' Scamp
2015 Ram Laramie Hemi, w/air suspension
30 years RV'ing
12 different RV's
RSchleder is offline   Reply With Quote
Old 04-24-2015, 09:24 AM   #4
Senior Member
 
Jim34RL's Avatar
 
Join Date: Feb 2015
Location: Oswego il
Posts: 1,195
Quote:
Originally Posted by salsa2me View Post
I have an Hemisphere 368 RLBH (2015) new... I connected the water hose to the black tank flush system and notice that no water was going in... and the flushing system was not working properly. I took it to the dealer and they claim that this is normal... they change the check valve and still I feel nothing is going in.... they also claim that is low pressure system and that's why a little water is coming out.... for me that sound BS.

any help out there for my issue...
You could have a toilet paper block at your outlet of the dump tube. I have had this happen more than once with all of my trailers. In talking to other campers and learning on how to keep the tank clean and the gages working I have developed a system for dumping. My system is:

1. Install a Clear Flush King Elbow either straight or 45 Deg off set ( I have both)

2. Open black tank dump valve and let this drain.

3. Fill up a 5 gallon bucket fresh water and dump down toilet bowl. You will need to dump between four and five buckets. DW does the toilet bowl flushing as I fill and watch the clear elbow.

4. Hook up the black tank flush and flush as the water is being dumped.

5. When the elbow runs clear water from the black tank you are done. Shut off the flushing water; let tank drain and than close the dumping valve.

6. Open and drain the gray tanks closing valves when completed. Gages work and the tanks are now empty.

I have been doing this for at least 10 years now and I do not have any issues with my tank gages nor a poorly draining black tank.
__________________
Jim W.
2016 34RL CC; 2008 Ram Mega Cab 2500HD, 6.7L, 68RFE 6 speed, 4X4, Smarty S67, TDR 112K+miles
Jim34RL is offline   Reply With Quote
Old 04-24-2015, 09:27 AM   #5
Senior Member
 
Join Date: Jul 2010
Location: Waynesville
Posts: 12,036
Quote:
Originally Posted by salsa2me View Post
I have an Hemisphere 368 RLBH (2015) new... I connected the water hose to the black tank flush system and notice that no water was going in... and the flushing system was not working properly. I took it to the dealer and they claim that this is normal... they change the check valve and still I feel nothing is going in.... they also claim that is low pressure system and that's why a little water is coming out.... for me that sound BS.

any help out there for my issue...
Sounds like the (Dealership?) has hired a BS Press Secretary! They don't have a Clue! Youroo!!
__________________
youroo is offline   Reply With Quote
Old 04-24-2015, 09:30 AM   #6
Senior Member
 
Oakman's Avatar
 
Join Date: Jul 2007
Location: Jefferson County, MO
Posts: 5,201
Easiest way to tell is put a clear elbow on the drain and see if water is coming out. That way you know for sure if your black tank flush is working. You can also lift the end of the sewer hose and see if water continues to come out while flushing. Although the clear elbow method is less smelly.
__________________


Bob and Joyce
2013 CC Silverback 29RL
2010 Ford F250 XL Crew Cab 6.4 liter diesel
ATU Local 788
Oakman is offline   Reply With Quote
Old 04-27-2015, 01:53 PM   #7
Boss Ox & Drovergirl
 
oxcamper's Avatar
 
Join Date: Feb 2014
Location: N.E. Ohio Snow Belt
Posts: 671
Quote:
Originally Posted by salsa2me View Post
I have an Hemisphere 368 RLBH (2015) new... I connected the water hose to the black tank flush system and notice that no water was going in... and the flushing system was not working properly. I took it to the dealer and they claim that this is normal... they change the check valve and still I feel nothing is going in.... they also claim that is low pressure system and that's why a little water is coming out.... for me that sound BS.

any help out there for my issue...


Sounds like more S than just plain old BS
Our Hemi 282RK you can hear the jets swirling when you put the black tank flush on. Your case is NOT NORMAL. When you have the tank flush on, you can open up the toilet trap in the bathroom and hear the jets.
There may be a crimp in the line but you won't know that unless you take the underbelly covering off. Sounds like a warranty issue to me.
__________________
Mark, Vicki, & Scout THE dog
2015 Hemisphere 282RK
2010 F250 Super Duty
1992 Goldwing Aspencade
oxcamper is offline   Reply With Quote
Old 04-30-2015, 11:14 PM   #8
Tyler & Connie Foxx
 
FoxxLandArk's Avatar
 
Join Date: Jan 2015
Location: Chicago
Posts: 48
We have a 2014 Salem Hemisphere Bh300, with a sealed underbelly! When we turn that Black Tank rinse system on you can hear it inside and outside. Your RV dealer sounds like as big a BS artist as mine does!!!
__________________

__________________
FoxxLandArk is online now   Reply With Quote
Reply

Tags
black, black tank, black tank flush, tank

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 02:54 PM.