Reply
 
Thread Tools Display Modes
Old 10-10-2015, 10:30 PM   #1
Senior Member
 
DougP47's Avatar
 
Join Date: Jan 2012
Posts: 327
Please help..Furnace no air blowing from floor duct

Turned the furnace on tonight and have no air coming from floor vents. What i thought was the intake for the furnace is blowing hot air. Work great for 2 years but not tonight. Its like the blower is running backwards or something changed. Any ideas? Please help
__________________

__________________


Ram 1500
Big Horn
Hemi 5.7 2011
Salem 30KQBSS 2012
DougP47 is offline   Reply With Quote
Old 10-10-2015, 10:55 PM   #2
Member
 
thevosmans's Avatar
 
Join Date: Apr 2014
Location: Labrador NL
Posts: 35
Is it blowing cold air from the ducts in your ceiling instead of hot air from your floor ducts?


Sent from my iPad using Forest River Forums
__________________

__________________
thevosmans is offline   Reply With Quote
Old 10-10-2015, 10:59 PM   #3
Senior Member
 
DougP47's Avatar
 
Join Date: Jan 2012
Posts: 327
Found the problem there is a cover on the blower only had 2 screws holding cover on. There's alot of pressure on that cover and tge screws fell out. Tomorrow there will be a few more screws and maybe aluminum duct tape.
__________________


Ram 1500
Big Horn
Hemi 5.7 2011
Salem 30KQBSS 2012
DougP47 is offline   Reply With Quote
Old 10-10-2015, 11:01 PM   #4
Member
 
thevosmans's Avatar
 
Join Date: Apr 2014
Location: Labrador NL
Posts: 35
Perfect! Have a great weekend camping and keep warm!!


Sent from my iPad using Forest River Forums
__________________
thevosmans is offline   Reply With Quote
Old 10-10-2015, 11:02 PM   #5
Senior Member
 
DougP47's Avatar
 
Join Date: Jan 2012
Posts: 327
Thevosmans Nope air coming from floor duct.
__________________


Ram 1500
Big Horn
Hemi 5.7 2011
Salem 30KQBSS 2012
DougP47 is offline   Reply With Quote
Old 10-10-2015, 11:04 PM   #6
Senior Member
 
DougP47's Avatar
 
Join Date: Jan 2012
Posts: 327
Thanks for checking in and helping me
__________________


Ram 1500
Big Horn
Hemi 5.7 2011
Salem 30KQBSS 2012
DougP47 is offline   Reply With Quote
Old 10-11-2015, 01:34 PM   #7
Senior Member
 
Dabmeb's Avatar
 
Join Date: Mar 2013
Posts: 259
Quote:
Originally Posted by DougP47 View Post
Found the problem there is a cover on the blower only had 2 screws holding cover on. There's alot of pressure on that cover and tge screws fell out. Tomorrow there will be a few more screws and maybe aluminum duct tape.
We had the same problem and the dealer missed it completely
__________________
Dabmeb is offline   Reply With Quote
Old 10-12-2015, 10:09 AM   #8
Senior Member
 
DougP47's Avatar
 
Join Date: Jan 2012
Posts: 327
Quote:
Originally Posted by Dabmeb View Post
We had the same problem and the dealer missed it completely
Debmeb maybe others will see this and make the necessary repair before the have to. Kinda stinks that it would only take a few screws for this not to happen at all. Safe travels
__________________


Ram 1500
Big Horn
Hemi 5.7 2011
Salem 30KQBSS 2012
DougP47 is offline   Reply With Quote
Old 10-12-2015, 11:04 AM   #9
Senior Member
 
DaveSchwartz's Avatar
 
Join Date: May 2014
Location: Waterloo Region
Posts: 717
I concur... if you have furnace airflow problems this is the first place to look. Mine was delivered with one of the two screws fallen out and the back panel half open - the air was just circulating within the equipment area and only the closest register had any airflow.
__________________
2015 Rockwood Signature UltraLite 8282WS Platinum, GY Marathon LRD, TST 507RV TPMS
2005 GMC 2500HD CCSB D/A, Curt E16, Prodigy P2, Garmin RV760LMT w/BC-20 b/u cam

Self restraint is for the young. I'm old and want it NOW!
DaveSchwartz is offline   Reply With Quote
Old 10-12-2015, 12:09 PM   #10
Senior Member
 
Dabmeb's Avatar
 
Join Date: Mar 2013
Posts: 259
Ours started with no air in the front at all and the bedroom way to hot.
The dealer say they found a hose disconnected below the shower and it got a little better after they fixed it but still not right. When I pulled the trim covers the end plate of the furnace fell off. One screw was missing and the clip on the other side was broken. One benefit of fixing it myself is I found the breaker for the rear stabilizers beside the furnace behind the trim panel and both wires were loose.
__________________

__________________
Dabmeb is offline   Reply With Quote
Reply

Tags
furnace

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 02:59 PM.