Reply
 
Thread Tools Display Modes
Old 12-14-2015, 01:19 PM   #1
Junior Member
 
Join Date: Dec 2015
Posts: 1
371REBH electrical issues

From the day we pulled our 2016 Sandpiper 371REBH off the lot we have had electrical problems. Is anyone else with this model having problems? It started out just blown fuses, which are easily replaced. But now (just one month after purchase) the slides and jacks will not function at all. It is currently in the shop, waiting for warranty approval. What are your experiences and thoughts about this. I'm wondering if we have a lemon or if the kinks are not worked out of the 2016s yet?!? We are new full-timers and have had nothing but issues.
__________________

__________________
WandeRNs is offline   Reply With Quote
Old 12-14-2015, 09:05 PM   #2
Senior Member
 
denali15's Avatar
 
Join Date: Mar 2015
Location: Canada
Posts: 122
Hey, our friends and us each bought new fully loaded 2016's in May.

We've had small issues that were easily fixed without going to the dealers. Neither of our unit needed any warranty work; except for the tires!
__________________

__________________
denali15 is offline   Reply With Quote
Old 12-15-2015, 09:50 AM   #3
Head Rambler
 
Join Date: Mar 2008
Location: Southwest Alabama
Posts: 4,322
Sounds like some wiring got pinched during the build and is now shorted out. They should be able to fix it and solve all those problems pretty easily once they get approval.
__________________
Salem 29RKSS Pushing a GMC Sierra 2500HD!
Gotta go campin!
Bama Rambler is offline   Reply With Quote
Old 12-17-2015, 02:14 PM   #4
Myaamia
 
Leathernek's Avatar
 
Join Date: Apr 2015
Location: Stafford VA
Posts: 38
Picked up our 2015 in April. No real issues so far.
__________________
Scott & Tammie
2015 F350 4x4
SRW 11,500 GRVW Pkg
2015 Sierra 371REBH
B&W Companion 20K
Leathernek is offline   Reply With Quote
Old 12-18-2015, 07:53 AM   #5
Senior Member
 
Join Date: Feb 2014
Location: Dacula, Georgia
Posts: 1,200
Let me share my "good" FR issue experience. ONCE FR HAS YOUR ISSUE ON RECORD, they WILL stand behind it and fix it even if warranty expires during the WAIT FOR REPAIR time. In YOUR CASE, just ensure you DOCUMENT the issues with the factory. They maintain excellent records. My issues did not occur until AFTER YEAR 1. I still have to go back to Goshen for a new roof install!! Trying to decide on waiting for 2016 Rally or go before!
Regardless, this should end my MAJOR issues.
__________________
SilverbackMel is offline   Reply With Quote
Old 12-19-2015, 04:55 PM   #6
Senior Member
 
Join Date: Jun 2015
Posts: 138
We've had ours 6 months now and have had a bunch of minor issues. As for electrical, we to kept blowing the main fuse on pump motor. Seemed like it happens every time we setup. I put a 30 amp in place of the 20 and haven't had an issue anymore. Then we had the lights above the recliner quit. They used wire nuts on the connection and one came loose. Other than that it's just been a bunch of other little issues. Annoying but not terrible.
__________________

__________________
Mikele is offline   Reply With Quote
Reply

Tags
electric, electrical

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 06:12 PM.