Thread Tools Display Modes
Old 08-10-2013, 03:32 PM   #1
Senior Member
5erDriver's Avatar
Join Date: Jun 2013
Posts: 172
InterVac central vac cutting out

Anyone having the same problem? The central vac in our 2013 365saq cuts out after a few minutes running. The bag is empty and the pipes are not blocked. Seems like a thermal fuse to me. It does come on again after a few minutes cooling. The manual does say it could cut out if overheated and if it has been installed in an airtight cavity where it can't stay cool enough when running. Next step will be unscrewing the whole unit and seeing if it can breathe back there.
2013 Sandpiper 365SAQ
2008 Ford F350 Super Duty
6.4L Powerstroke Long Bed CC
5erDriver is offline   Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Virginia Campgrounds

Reviews provided by is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 02:01 PM.