Reply
 
Thread Tools Display Modes
Old 07-24-2016, 09:59 PM   #1
Junior Member
 
Join Date: Jul 2016
Posts: 1
Lights and ACT not working

Just picked up my Sandpiper 2016 380bh5 Friday. Started having problems as soon as we got it to the site. Sales folks are very unhelpful and argumentative. Now 2 days later no lights and no ac. Has anyone experienced this? If so what can we do to fix it? If not does anyone have experience with lemon laws?
__________________

__________________
Tulara is offline   Reply With Quote
Old 07-24-2016, 10:13 PM   #2
Senior Member
 
Join Date: Jun 2012
Posts: 4,878
It's hard to diagnose your problem from what little you've provided. However, my first suggestion is to look for a circuit breaker or two inside the campground pedestal. Make sure it's turned ON.

My 2nd suggestion is to get yourself one of these 120VAC outlet checkers from Walmart



and one of these 30 amp to 15 amp adapters from Walmart or your local RV dealer (or even the campground store)



Plug the adapter into the campground pedestal, then plug the circuit checker into the adapter and make sure you're getting proper 120VAC from the pedestal.

Finally, make sure the main breaker is turned on in your camper. Open your fuse panel and check the breakers.

More detail about your problem would help. I initially read you post to say you never had AC, but on second reading, it sounds like you might have had AC for a while and then lost it. If you had it and lost it, I'm guessing you tripped one of the circuit breakers I've discussed.

Note: If you are running the AC, don't try to run the water heater on electric, the fridge on electric, or the microwave (or a toaster). These are all high wattage (i.e., high power, i.e., high current draw) devices. If you have a 30 amp system, trying to run the AC with any of these will almost always trip a circuit breaker.
__________________

__________________
1988 Coleman Sequoia - popup (1987-2009) - outlasted 3 Dodge Grand Caravans!
2012 Roo19 - hybid (2012-2015)

2016 Mini Lite 2503S - tt (2015 - ???)
2011 Traverse LT, 3.6L, FWD
2009 Silverado 1500 Ext Cab, 5.3L, 4x4, 3.73
2016 Silverado 2500HD Dbl Cab, 6.0L 4x4, 4.10
rockfordroo is online now   Reply With Quote
Old 07-25-2016, 02:19 PM   #3
Senior Member
 
chop249's Avatar
 
Join Date: Nov 2015
Location: Burleson, Tx.
Posts: 263
380 BH is a 5er so should be 50amp not 30amp. Same holds true however but you should be able to run the a/c with the water heater without a problem unless they mistakenly put them on the same circuit breaker inside the breaker box by your stairs.
__________________
Bob
2011 Ford F350 Lariat
2016 Sandpiper 381RBOK with an extremely CRAPPY A/C!!!
Nights Camped: 2010 = 14/11 = 27/12 = 13/13 = 10/14 = 30/15 = 47/16 = 30/17 = 13
chop249 is offline   Reply With Quote
Old 07-25-2016, 03:29 PM   #4
Senior Member
 
Join Date: Jun 2015
Posts: 138
My cord has a blue Led'sthat lights up when power is present. Its on the male side that plugs into the campground pedestal. Very noticeable when they are lit up.
__________________
Mikele is offline   Reply With Quote
Old 11-28-2016, 12:09 PM   #5
Junior Member
 
Join Date: Oct 2016
Posts: 10
I had the same issue with my 17' 376BHOK and found the main "shore" power plug on the coach itself. I pulleded it out to find all 3 wire jamb screws were loose giving me a bad connection. I found it soon enough where it only burned up my power converter. My selling dealer is shipping me a new one only cause I offered to replaced it myself because I didn't want my rig to sit up there for 6 months Best of luck to ya
__________________
dritson84 is offline   Reply With Quote
Old 11-28-2016, 12:46 PM   #6
Site Team
 
Mr. Dan's Avatar
 
Join Date: Mar 2014
Location: Grayson County, Texas
Posts: 4,226
Quote:
Originally Posted by dritson84 View Post
I had the same issue with my 17' 376BHOK and found the main "shore" power plug on the coach itself. I pulleded it out to find all 3 wire jamb screws were loose giving me a bad connection. I found it soon enough where it only burned up my power converter. My selling dealer is shipping me a new one only cause I offered to replaced it myself because I didn't want my rig to sit up there for 6 months Best of luck to ya
dritson84, this thread has had no activity since late July. Obviously, the OP no longer has an issue nor did he/she report success/failure.
__________________

__________________
SEARCH is your friend!
FR Wildcat 295RSX / GMC Sierra

Nights Camped: 2013 = 49 / 2014 = 74 / 2015 = 74 / 2016 = 85 / 2017 = 14; booked = 28
Mr. Dan is online now   Reply With Quote
Reply

Tags
light

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 11:29 AM.