Reply
 
Thread Tools Display Modes
Old 10-08-2012, 04:16 AM   #1
Member
 
robertc68's Avatar
 
Join Date: Sep 2011
Posts: 39
bunk lights and fantastic fan not working

My bunk lights( all 4) and fantastic fan are not working.I have looked at the fuses,breakers and gfi,which are all on,however when I checked them with a multi meter there is no power to them.I have no clue,the plugs and ceiling lights work.Its like there is another cutoff some place.Does anybody have and idea,I have been trying ti figure it out for 5 days. Thanks..
__________________

__________________
robertc68 is offline   Reply With Quote
Old 10-08-2012, 10:14 AM   #2
Senior Member
 
Road-King's Avatar
 
Join Date: Jul 2012
Location: TN
Posts: 645
Your bunk lights and Fantastic fan should all be 12 volt. So you need to look at your 12 volt power supply. There should be a breaker somewhere near the battery, follow the positive wire coming from the battery to find it. You should be able to reset it.

If that's not it your next step is the converter. Do these lights and fan work when hooked up to shore power? The converter is the same unit inside your TT that holds your breakers and fuses.
__________________

__________________
Russ & Kim
2014 Alpine 3600RS
2007 Dodge Ram 3500 5.9 4X4
2008 Harley Davidson Road King 105th Anniversary
(2011-5 bad year)(2012-40)(2013-45)(2014-23)
Road-King is offline   Reply With Quote
Old 10-08-2012, 01:22 PM   #3
Moderator Emeritus
 
Dave_Monica's Avatar
 
Join Date: Sep 2007
Location: Ontario, Canada
Posts: 4,329
You've only mentioned bunk lights and Fantastic fan, so I'm assuming that other 12V lighting is working. You need to check your 12V fuses on your power center. Don't assume that if you don't see a red LED light (indicating a blown fuse) that all is well. The panel fuses should be identified...try a new fuse.

Dave
__________________


Nights camped in 2013 - 55, 2014 - 105, 2015 - 63
Dave_Monica is offline   Reply With Quote
Old 10-08-2012, 01:28 PM   #4
Member
 
robertc68's Avatar
 
Join Date: Sep 2011
Posts: 39
Yes I have checked every fuse.the main lights are working just the fan and bunk that will not come on.
__________________
robertc68 is offline   Reply With Quote
Old 10-08-2012, 01:37 PM   #5
Senior Member
 
Road-King's Avatar
 
Join Date: Jul 2012
Location: TN
Posts: 645
Are you hooked to shore power?
__________________
Russ & Kim
2014 Alpine 3600RS
2007 Dodge Ram 3500 5.9 4X4
2008 Harley Davidson Road King 105th Anniversary
(2011-5 bad year)(2012-40)(2013-45)(2014-23)
Road-King is offline   Reply With Quote
Old 10-08-2012, 01:55 PM   #6
Moderator Emeritus
 
Dave_Monica's Avatar
 
Join Date: Sep 2007
Location: Ontario, Canada
Posts: 4,329
Quote:
Originally Posted by robertc68 View Post
Yes I have checked every fuse.the main lights are working just the fan and bunk that will not come on.
Are the fan and the bunk lights identified as the same circuit or separate circuits? Have you checked for loose connections at the 12V fuse panel?

Dave
__________________


Nights camped in 2013 - 55, 2014 - 105, 2015 - 63
Dave_Monica is offline   Reply With Quote
Old 10-08-2012, 05:10 PM   #7
Member
 
robertc68's Avatar
 
Join Date: Sep 2011
Posts: 39
Even with shore power,they will not work.Basically the fan was running,I stepped away for a few minutes when I came back it was off. Totally lost,I checked the fuse by the battery its fine.
__________________
robertc68 is offline   Reply With Quote
Old 10-08-2012, 05:18 PM   #8
Member
 
robertc68's Avatar
 
Join Date: Sep 2011
Posts: 39
Quote:
Originally Posted by Dave_Monica View Post
Are the fan and the bunk lights identified as the same circuit or separate circuits? Have you checked for loose connections at the 12V fuse panel?

Dave
not sure if they are on the same circuit,my fuse panel does not label the fans.
__________________
robertc68 is offline   Reply With Quote
Old 10-08-2012, 05:22 PM   #9
Senior Member
 
Join Date: Jun 2012
Location: Washington DC
Posts: 332
Don't know if this will help but there are ALOT of fuses behind the main control board too. I know remote ones are hidden there as well but maybe it's back there. If you haven't solved the problem , send me a PM and I will give you a suggestion that worked for me when my converter blew.
__________________

__________________
2012 Ford F-350 6.7L CC SRW w/FX4
2013 Forest River Sierra 365SAQ
Beausdog is offline   Reply With Quote
Reply

Tags
fan

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 02:48 PM.