Reply
 
Thread Tools Display Modes
Old 05-30-2019, 09:00 AM   #1
Junior Member
 
Join Date: May 2019
Posts: 1
LP/Carbon Dioxide monitor

Monitor continues to “sound off” even after resetting. Replaced unit but still sends alarm. LP has been disconnected for two seasons now. Checked charge on battery and it appears to have full charge. Suggestions?
__________________

Jwreyn is offline   Reply With Quote
Old 05-30-2019, 09:05 AM   #2
Senior Member
 
Join Date: Feb 2018
Location: TEXAS
Posts: 1,203
The battery would be my first guess. The alarm going off is usually our first indication that the battery has problems.

If it's not that, then I'd check for other sources of fumes. Some cleaning products will set them off as well as things like sewer gas.
__________________

__________________
Happy Camping!

2015 Dynamax REV 24TB class C
2nd rig 2006 Toyota Tundra &
2010 Cikira 21RB 19' travel trailer
Reverse_snowbird is offline   Reply With Quote
Old 05-30-2019, 10:19 PM   #3
Junior Member
 
Join Date: Apr 2019
Posts: 10
I was sealing some plumbing with spray foam and set it off too.
__________________
2018 Ram 2500
2019 Sierra 384QBOK
mlamar is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Featured Campgrounds

Reviews provided by


Disclaimer:

This website is not affiliated with or endorsed by Forest River, Inc. or any of its affiliates. This is an independent, unofficial site.




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 06:31 PM.