Reply
 
Thread Tools Display Modes
Old 03-23-2018, 07:24 PM   #1
Member
 
Join Date: Aug 2017
Posts: 54
Relay switch

Hello everyone, anyone know where the relay switch is on a Forest River Sierra 5th wheel? My slides keep tripping the relay when I try to put them out. Thanks.
__________________

Mcnet22 is offline   Reply With Quote
Old 03-23-2018, 08:43 PM   #2
Member
 
Join Date: Oct 2017
Posts: 60
Hydraulic slides?
If so I believe it will be located in the curb side front compartment. That's where all of my wiring to the pump is located.
__________________

whitewinghunter is offline   Reply With Quote
Old 03-23-2018, 08:50 PM   #3
Member
 
Join Date: Aug 2017
Posts: 54
They are hydraulic, I will check that, thanks
Mcnet22 is offline   Reply With Quote
Old 03-25-2018, 08:40 AM   #4
Junior Member
 
Join Date: May 2017
Posts: 3
Had the same problem with mine, I have hydraulic slides. The breaker should be an automatic reset type and would be close to the battery as possible. Could be 3 things wrong with. 1) bad pump motor drawing to many amps 2) bad breaker, tripping before itís supposed to 3) batteries are bad/to low on power. Mine was a bad breaker, got a new one for $8 and good to go. Start with that, itís the cheapest. Also does it trip only on battery power or does trip also on shore power?
Ross.Pajich is offline   Reply With Quote
Old 03-25-2018, 09:55 AM   #5
Member
 
Join Date: Aug 2017
Posts: 54
It trips both on battery, and when plugged in. I tested the battery, it's good. Is the breaker in the breaker box or by the battery? Thanks
Mcnet22 is offline   Reply With Quote
Old 03-27-2018, 06:02 AM   #6
Junior Member
 
Join Date: May 2017
Posts: 3
Sorry for the long delay, didn’t realize you replied. Breaker would be close to battery. Mine is located in the front left compartment right above battery. Follow the red 4ga wires to locate. Do you know what a automatic reset automotive breaker looks like? My camper is still in storage, so can’t send pictures for a week or two.
Ross.Pajich is offline   Reply With Quote
Old 03-27-2018, 07:22 AM   #7
Phat Phrog Stunt Team
 
AquaMan's Avatar
 
Join Date: Apr 2012
Location: Tipp City, OH
Posts: 7,114
The breaker is most likely mounted to the sidewall on a bus bar in front compartment under pinbox. I, under direction from FR, installed a heavier breaker and solved my issue. I believe I went to a 40amp breaker, but can't be certain.
__________________
2016 Georgetown 364TS
2017 Jeep Rubicon Recon toad
Nights Camped 2019 - 17
AquaMan is offline   Reply With Quote
Old 03-27-2018, 07:43 AM   #8
Member
 
Join Date: Aug 2017
Posts: 54
Thanks for the help, much appreciated. Ross, I have never seen one prior to this camper. My old TT had the same issue, but the breaker was mounted right on the bumper and was very small.
__________________

Mcnet22 is offline   Reply With Quote
Reply

Tags
switch

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Featured Campgrounds

Reviews provided by


Disclaimer:

This website is not affiliated with or endorsed by Forest River, Inc. or any of its affiliates. This is an independent, unofficial site.




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 05:14 AM.