Reply
 
Thread Tools Display Modes
Old 07-27-2015, 07:45 AM   #1
Member
 
Bigdale1's Avatar
 
Join Date: Jul 2015
Posts: 33
Tank indicator lights not working

I have a 2001 Sierra lite trailer and the water tank, grey, black water and battery indicator lights stop working any help on a fix?
__________________

Bigdale1 is offline   Reply With Quote
Old 09-07-2015, 07:21 AM   #2
Senior Member
 
Join Date: Jan 2014
Location: West Carrollton, Ohio
Posts: 704
Did you ever find out what happened? Did you have power to it ? Check your fuses and breakers?
__________________

OKI Marine is offline   Reply With Quote
Old 09-10-2015, 02:17 AM   #3
Member
 
Bigdale1's Avatar
 
Join Date: Jul 2015
Posts: 33
Did all that to no avail
Bigdale1 is offline   Reply With Quote
Old 09-10-2015, 05:18 AM   #4
Senior Member
 
Witch Doctor's Avatar
 
Join Date: Feb 2012
Location: Clarksville Va.
Posts: 10,112
Quote:
Originally Posted by Bigdale1 View Post
Did all that to no avail
If they are all out it might be a ground problem.
__________________
Coachmen M/H
Concord
2018 / 300 DSC

Witch Doctor is offline   Reply With Quote
Old 09-12-2015, 04:16 PM   #5
Member
 
Bigdale1's Avatar
 
Join Date: Jul 2015
Posts: 33
Where should I look to check the ground?
Bigdale1 is offline   Reply With Quote
Old 09-12-2015, 05:04 PM   #6
Senior Member
 
Witch Doctor's Avatar
 
Join Date: Feb 2012
Location: Clarksville Va.
Posts: 10,112
Quote:
Originally Posted by Bigdale1 View Post
Where should I look to check the ground?
Behind the panel you will see a bunch of white wires tied together, I had one that was lose once and couldn't get some outside lights on.
__________________
Coachmen M/H
Concord
2018 / 300 DSC

Witch Doctor is offline   Reply With Quote
Old 09-12-2015, 06:13 PM   #7
Member
 
Bigdale1's Avatar
 
Join Date: Jul 2015
Posts: 33
Behind the fuse panel or the panel where the tank lights are?
Bigdale1 is offline   Reply With Quote
Old 09-12-2015, 06:34 PM   #8
Senior Member
 
bubbles's Avatar
 
Join Date: Dec 2012
Posts: 4,363
Typically, those indicators are LED's on a circuit card mounted to the panel. Might pull the panel and check to make sure the connector is connected. Disregard if yours is different.
bubbles is offline   Reply With Quote
Old 09-12-2015, 09:06 PM   #9
Site Team
 
Mr. Dan's Avatar
 
Join Date: Mar 2014
Location: Grayson County, Texas
Posts: 12,860
My panel may not be like yours, but on mine the mentioned circuit card is the green circuit board in the left side of the pic - near my thermostat.
Click image for larger version

Name:	ImageUploadedByTapatalk1442109970.685982.jpg
Views:	95
Size:	365.4 KB
ID:	88477


Sent (I think)
__________________
SEARCH is your friend!
FR Wildcat 295RSX / GMC Sierra

Nights Camped: '13 = 49/'14 = 74/'15 = 74/'16 = 85/'17 = 110/'18 =111/'19 = 86; booked = 0
Mr. Dan is offline   Reply With Quote
Old 09-13-2015, 08:29 PM   #10
Member
 
Bigdale1's Avatar
 
Join Date: Jul 2015
Posts: 33
Thank u so much I have to go get my trailer and look at it I let u know what I find out!😊
Bigdale1 is offline   Reply With Quote
Old 09-15-2015, 01:38 AM   #11
Member
 
Bigdale1's Avatar
 
Join Date: Jul 2015
Posts: 33
Click image for larger version

Name:	ImageUploadedByForest River Forums1442298909.388946.jpg
Views:	91
Size:	75.1 KB
ID:	88719Click image for larger version

Name:	ImageUploadedByForest River Forums1442298928.105092.jpg
Views:	89
Size:	45.0 KB
ID:	88720

Used ohm meter power is getting to the circuit board, it work for a quick second today then didn't come back on.
Bigdale1 is offline   Reply With Quote
Old 09-15-2015, 02:01 AM   #12
Just a member
 
kandl's Avatar
 
Join Date: Jul 2011
Location: Cool Pool, AB
Posts: 903
Quote:
Originally Posted by Bigdale1 View Post
Used ohm meter power is getting to the circuit board, it work for a quick second today then didn't come back on.
Suspect you've got a broken circuit or a bad IC on the board. Have you tried to source a new board?
__________________
K&L + the Wild Bunch
TT: 2011 Rockwood 8293RKSS
TV: 2019 Dodge Ram 3500

kandl is offline   Reply With Quote
Old 09-16-2015, 12:50 PM   #13
Member
 
Bigdale1's Avatar
 
Join Date: Jul 2015
Posts: 33
There is actually a Forest River plant by my house, I went there, super rude people there, on another note, I got someone who took the time to answer my question, and look at the board. He told me he thinks half of the board is burned out. He sent me to a place where I can order a new one, and I am waiting to here from them I'll keep ya posted.
__________________

Bigdale1 is offline   Reply With Quote
Reply

Tags
cat, light, tank

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Forest River, Inc. or any of its affiliates. This is an independent, unofficial site.



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 05:07 AM.


×