Reply
 
Thread Tools Display Modes
Old 07-31-2012, 06:26 PM   #1
Junior Member
 
Join Date: Jul 2012
Posts: 1
2011 Wildcat FLR34

Hello,
I have a new leftover Wildcat FLR34 fifthwheel and am having problems with the Electrical panel. The 15 amp fuse blows out everytime I add a lighjtbulb in the kitchen. If I don't add a bulb it is ok except the red light next to the fuse will illuminate (loose power for lights in kitchen). I can push on the fuse until the light stays off and I have power back but after a short time the light is back on. I changed the fuse a couple of times but same result. I'm not sure if there is a loose connection for that circuit in the board. It seems to have something to do with the same overhead light above the sink (can't add a bulb because it blows fuse). Also, the surround sound on the entertainment system works fine except for the subwoofer in the ceiling does not appear to work at all. Any ideas?? Thanks.
Alan
__________________

__________________
adbrown is offline   Reply With Quote
Old 08-02-2012, 11:51 PM   #2
Junior Member
 
Join Date: May 2012
Posts: 9
Are you putting in a 2 contact bulb? If you try to install a single contact bulb you will blow the fuse.
__________________
cellman is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 02:25 PM.