Reply
 
Thread Tools Display Modes
Old 08-07-2015, 12:09 AM   #1
Newbie!!
 
Join Date: Apr 2015
Location: Virginia
Posts: 12
Rear Jack Problem

Hi there folks,
I have encountered a problem with our new Wildcat 312 QBX. The right rear jack stabilizer has stopped working. In a way it appears "stripped". I took a video of it and have included it in this post (if it will take it). I appears that the metal drive of the motor is moving but the black transmission shaft and the screw shaft does not move. Any suggestions? Has anyone had this issue before? I dont mind fixing myself, just want to know what is going on so that if I need a part, I can ask for the right thing. Thanks for your time!
Fred and Brenda
Attached Files
__________________

__________________
dadbizdoc is offline   Reply With Quote
Old 08-07-2015, 12:47 AM   #2
Senior Member
 
Join Date: Aug 2009
Location: Northern California
Posts: 145
I couldn't get the video to load perhaps because I am using my iPad. Just a thought...Did the other side go down okay? When I first used my new RV, I found that the rear jacks operated differently than the front ones. The front ones both go down at the same time. However, with the rear jacks, one goes all of the way down first and then the other one goes down.
__________________

__________________
2015 Rockwood 8329SS TT
2004 Chevy 2500HD D/A 4X4 CC SB
Andersen Weight Distribution hitch
lakejumper is offline   Reply With Quote
Old 08-07-2015, 12:56 AM   #3
Newbie!!
 
Join Date: Apr 2015
Location: Virginia
Posts: 12
jumper,
Thanks for the reply. You are right, I have two separate switches on the back for each jack, so they work independently. I can get the left one to work correctly, just a problem with the right one. Video is in mp4 format, made from a mac so am surprised it doesn't work for you. Thanks again.
Fred
__________________
Fred and Brenda
Western Virginia, Beautiful Shenandoah Valley
2016 Wildcat 312 QBX
2007 Ford F350 Dualy
dadbizdoc is offline   Reply With Quote
Old 08-07-2015, 08:17 AM   #4
Member
 
Join Date: Jul 2015
Posts: 36
I am having problems with my new 312bhx.... They went up but they won't come down.... I got lots of suggestions from the posting I did about it ..... Just have not had the time to check the last few out


The Goat Belly from Texas
2016 Wildcat 312bhx
2011 Ford F-250 diesel
__________________
sears532 is offline   Reply With Quote
Old 08-07-2015, 08:33 AM   #5
Mod free 5er
 
Join Date: Mar 2008
Location: Concord, NC
Posts: 24,215
Quote:
Originally Posted by dadbizdoc View Post
Hi there folks,
I have encountered a problem with our new Wildcat 312 QBX. The right rear jack stabilizer has stopped working. In a way it appears "stripped". I took a video of it and have included it in this post (if it will take it). I appears that the metal drive of the motor is moving but the black transmission shaft and the screw shaft does not move. Any suggestions? Has anyone had this issue before? I dont mind fixing myself, just want to know what is going on so that if I need a part, I can ask for the right thing. Thanks for your time!
Fred and Brenda
The pin appears to be sheared that connects the coupler to the screw.
__________________
OldCoot is offline   Reply With Quote
Old 08-07-2015, 04:30 PM   #6
Newbie!!
 
Join Date: Apr 2015
Location: Virginia
Posts: 12
Coot,
I will get up in there and check to see if there is some sort of sheer pin. Great idea.
Thanks for replying.
Fred
__________________
Fred and Brenda
Western Virginia, Beautiful Shenandoah Valley
2016 Wildcat 312 QBX
2007 Ford F350 Dualy
dadbizdoc is offline   Reply With Quote
Old 08-07-2015, 08:32 PM   #7
Senior Member
 
67cudafb's Avatar
 
Join Date: Dec 2014
Location: N FLA
Posts: 138
Our wildcat is at the dealer with same problem on the left rear. I have been told that they ordered new motor and drive to fix the problem. So I guess there is no repair just replace. The good thing is you can put them up and down with 3/4" socket on the outside of jack.
__________________

__________________
1967 Barracuda fastback
2015 Wildcat MK 333
2010 Ram 2500 Mega-cab
67cudafb is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 12:05 PM.