Reply
 
Thread Tools Display Modes
Old 05-10-2016, 06:13 PM   #1
Junior Member
 
Kayakerfl's Avatar
 
Join Date: Mar 2016
Location: Pensacola
Posts: 17
2016 Wildwood 254 RLXL

Just returned from my first camping trip in Arkansas in my new Wildwood. While I was there I found out that my Black, Grey and Fresh water tank monitors do not work (backed up into the shower). Then the LED strip under the awning only half is still working. And last parts of the mounding inside has fallen off. Is anyone else having issues with a new travel trailer like I am? Concerned new owner.


Military Retired
Proud American
__________________

__________________
Kayakerfl is offline   Reply With Quote
Old 05-11-2016, 11:50 AM   #2
Head Rambler
 
Join Date: Mar 2008
Location: Southwest Alabama
Posts: 4,322
Many RV's have a few problems that need to be sorted out, but hopefully once you get those fixed it'll be smooth sailing for a while.
__________________

__________________
Salem 29RKSS Pushing a GMC Sierra 2500HD!
Gotta go campin!
Bama Rambler is offline   Reply With Quote
Old 05-11-2016, 08:27 PM   #3
Junior Member
 
Kayakerfl's Avatar
 
Join Date: Mar 2016
Location: Pensacola
Posts: 17
Thank you, makes me feel hopeful.


Military Retired
Proud American
__________________
Kayakerfl is offline   Reply With Quote
Reply

Tags
wildwood

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 05:56 PM.