Reply
 
Thread Tools Display Modes
Old 04-17-2016, 12:42 PM   #1
Junior Member
 
Join Date: Oct 2015
Posts: 9
Furnace issues... '15, 28' DbHD

Has anyone run across a good post talking through furnace running issues?
No issue with water heater, oven, or burners, and space heater has been keeping us warm enough.
Would like to sort this out... I don't like it when things don't work.
Topics I have found so far are listed below.

Start-up process
Thermostat settings
Vent covers/back pressure
Propane tank fill level
Outside air temp and propane pressure efficiency
Pressure valves
__________________

__________________
Jhkahuna is offline   Reply With Quote
Old 04-17-2016, 02:12 PM   #2
Senior Member
 
fonzie's Avatar
 
Join Date: Sep 2010
Location: Eastern Ontario
Posts: 3,237
https://www.google.ca/search?q=furna...DOzkjgTqu6WQCQ
__________________

__________________
Fonzie
2011 Rockwood 8319SS with ProPride 3P hitch/GoodYear Marathons/TST TPMS 507
2008 F250 Lariat CC SB 6.8L V10 4.10 axle ratio (NITTO TERRA GRAPLER G2 LT275/65R20E)
Yamaha 3000iseb generator:Progressive Ind. EMS-HW30C : Eastern Ontario
Nights Camped: 2011(21) 2012(36) 2013 (17) 2014 (18) 2015 (18) 2016 (36) 2017 (32)
fonzie is offline   Reply With Quote
Old 04-17-2016, 03:14 PM   #3
Junior Member
 
Join Date: Oct 2015
Posts: 9
I guess I just need to be more patient... Works fine after fourth restart.
__________________
Jhkahuna is offline   Reply With Quote
Old 04-17-2016, 03:20 PM   #4
Senior Member
 
fonzie's Avatar
 
Join Date: Sep 2010
Location: Eastern Ontario
Posts: 3,237
Quote:
Originally Posted by Jhkahuna View Post
I guess I just need to be more patient... Works fine after fourth restart.
line needed to be purged of air......good that it is working..
__________________
Fonzie
2011 Rockwood 8319SS with ProPride 3P hitch/GoodYear Marathons/TST TPMS 507
2008 F250 Lariat CC SB 6.8L V10 4.10 axle ratio (NITTO TERRA GRAPLER G2 LT275/65R20E)
Yamaha 3000iseb generator:Progressive Ind. EMS-HW30C : Eastern Ontario
Nights Camped: 2011(21) 2012(36) 2013 (17) 2014 (18) 2015 (18) 2016 (36) 2017 (32)
fonzie is offline   Reply With Quote
Old 04-18-2016, 04:48 PM   #5
Senior Member
 
Join Date: May 2015
Posts: 925
Quote:
Originally Posted by fonzie View Post
line needed to be purged of air......good that it is working..
Sounds like that was the problem. Dealers should tell people to lite their stove top for 3 or 4 minutes before playing with their furnace. Unfortunately very few tell anyone that.

A friend of mine had trouble keeping his furnace lit. He called his dealer who asked him if he had lit his stove top burners for a few minutes to get the air out. He asked the dealer, no, didn't you? Of course the answer was no. I to do it after changing both tanks when they went empty on me one time. Furnaces can be finicky! I would think the hot water tank would be also but I have never had a problem with it.

Jim
__________________
07 Dodge 1500 crew cab with 20" wheels, 08 Forest River Rockwood Signature Ultra-lite 8280SS
"The reasonable man adapts himself to the world; the unreasonable one persists in trying to adapt the world to himself. Therefore, all progress depends on the unreasonable man."
George Bernard Shaw
oldtool2 is offline   Reply With Quote
Reply

Tags
furnace

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 01:46 AM.