Thread Tools Display Modes
Old 06-22-2016, 02:19 PM   #11
Senior Member
Join Date: Jan 2016
Location: Benbrook, Tx
Posts: 214
Had similar issue with mine. Turned out to be a loose battery cable connection. Tightened and worked like a charm.

Dwayne and Susan
Jiro and Phoebe-4 legged family members
Mike and Dana - Traveling buddies
2016 Ford F350 XLT 6.7 Powerstroke DRW 4X4
2016 Brookstone 395RL
dwayneb236 is online now   Reply With Quote
Old 06-23-2016, 09:18 PM   #12
kittlecat's Avatar
Join Date: Jun 2016
Location: Michigan
Posts: 57
Electric tongue jack troubles

I had a TT with an electric tongue jack that started working intermittently. Turned out moisture had gotten inside where the fuse was housed near the battery (on my unit) and was causing the tongue jack to malfunction. I sprayed WD40 on the end of the fuse and reinserted it and that took care of the problem.

kittlecat is offline   Reply With Quote

battery, hitch, power

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Virginia Campgrounds

Reviews provided by is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 10:49 PM.