Reply
 
Thread Tools Display Modes
Old 01-23-2011, 08:02 PM   #1
Junior Member
 
Join Date: Jan 2011
Posts: 10
Heat?

OK we were out in the camper this weekend. It was 21deg. and we went to bed with the heat on (suburban electronic ignition) we woke up to cold noses. We covered up the kids and tried to get the heat to come back on with no luck. Note that the camper is new to us and this was our second outing and had not gotten a back up heater yet. The heater would blow cold air only. We had plenty of propane and we were hooked to electricity. When it would blow cold air we smelt propane coming thru the vent and decided to stop messing with it. We stayed in hotel the next nite. Went to load up and I tried it again. Same results. Drive 5 hours back home. I tried it again and it worked. I am really frustrated. What could be the problem? ? Hope I did not get a lemon.
Kperk
__________________

__________________
kperk is offline   Reply With Quote
Old 01-23-2011, 10:45 PM   #2
Moderator Emeritus
 
Join Date: Nov 2008
Location: Winston-Salem, NC
Posts: 2,381
Sketchy description of the problem, and may be hard to duplicate. When a propane appliance doesn't work, you need to verify you have propane in the rv. I don't mean just got the tanks filled yesterday. Would the stove light, run enough hot water to make to water heater come on. You said you smelled propane, don't know anything about year or model, but did your propane detector go off? If not, it needs checking, if indeed you smelled propane. You could have had a frozen regulator, in which case, if it was warmer when you got home, it started working. You could be very low on propane. again, heat changes pressure, so if was warmer when rechecked, all might seem well. You could have a loose wire/bad connection. You could have too much stuff to keep guessing. Need to duplicate the problem. Then start with propane flow in the rest of the rv. We can help after that.
__________________

__________________
LadyWindrider
2012 Ford F250 ext. Cab 4x4
2002 Jeep Wrangler Sahara
2008 Yamaha V-Star 650 Classic

2008 Work and Play 18LT
LadyWindrider is offline   Reply With Quote
Old 01-24-2011, 08:06 AM   #3
Junior Member
 
Join Date: Jan 2011
Posts: 10
Yes we had propane to the rest of the camper; the stove, oven, water heater, and refrigerator was functioning properly on the propane. The regulator was not froze. When I wrote this post it was working and then it happened again... Once it got to the set temp in the trailer which it was 25 deg. it would not come on again just blew cold air. I am taking it in today to have them look at it.
__________________
kperk is offline   Reply With Quote
Old 01-25-2011, 09:51 AM   #4
Junior Member
 
Join Date: Jan 2011
Posts: 10
It was a Thermostat that was going out.

Thanks
__________________
kperk is offline   Reply With Quote
Old 01-25-2011, 10:31 AM   #5
CLASS "A" Senior Member
 
cfsoistman's Avatar
 
Join Date: Nov 2008
Location: Upperco, Maryland
Posts: 3,135
Quote:
Originally Posted by kperk View Post
It was a Thermostat that was going out.

Thanks
T-Stat was bad or loose wire connection at T-Stat?
__________________

2007 Georgetown 370TS
aka - RAYNMKR

Driver: Charlie
Navigator: Sheri
cfsoistman is offline   Reply With Quote
Old 01-25-2011, 10:37 AM   #6
Junior Member
 
Join Date: Jan 2011
Posts: 10
Service order said that the T-Stat was replaced??
__________________
kperk is offline   Reply With Quote
Old 01-25-2011, 10:44 AM   #7
CLASS "A" Senior Member
 
cfsoistman's Avatar
 
Join Date: Nov 2008
Location: Upperco, Maryland
Posts: 3,135
Quote:
Originally Posted by kperk View Post
Service order said that the T-Stat was replaced??
Good to hear you're back up and running.
Keep an eye out near the end of February at Walmart for deep discounted electric matress pads and blankets. We picked up Queen blankets for $20 each and King Matress Pads for $10 last year. They're good to have especially when the furnace goes out and also helps to save propane by keeping the t-stat set down at night.
__________________

__________________

2007 Georgetown 370TS
aka - RAYNMKR

Driver: Charlie
Navigator: Sheri
cfsoistman is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 03:37 PM.